Help setting up Nicotine / Port Forwarding

This used to be fairly simple, but for some reason I can’t seem to get this right. I’ve set port forwading on my Arris modem:

And I’ve tried stopping Fedora’s firewall:

sudo systemctl stop firewalld

All to no avail. I always end up seeing the same message on Nicotine:

I even tried enabling UPnP, after installing python3-miniupnpc but I get the exact same result.

As a last resort I’ve tried adding my IP to the modem’s DMZ and I still end up at the same place, same message.

Oh, in case you’re wondering, I have selinux disabled.

What’s happening? What am I missing?