Haven't been able to connect my PS4 dualshock controller to my PC since F38

Hi all,

I’ve been unable to establish a successful connection to my PS4 Dualshock controller since about F38. I’m not sure why this occurred, I don’t mess with any bluetooth packages myself. The behavior is as follows:

The controller is picked up on a bluetooth scan (via the widget, bluetoothctl, blueman, I’ve tried them all), and I am able to mark it as trusted and even pair with it. However, when trying to connect after pairing, it connects for about a second then fails. Bluetoothctl and my GUI apps report this error:


Looking at the bluetooth.service logs I see:

src/service.c:service_probe() input-hid profile probe failed for <MAC>

I’ve tried setting ControllerMode = bredr in my /etc/bluetooth/main.conf, I’ve tried deleting my .config/pulse contents (it seems there’s some issue with bluez and not having pulseaudio, which I believe is the case for Fedora. Maybe it’s cause the dualshock also has audio transmission capability), all to no avail.

I believe in the 8 months I’ve had this behavior, I got my controller to connect for one session. But it looks like I’m unable to reproduce that.

Any other potential advice for this?

My system info:

Operating System: Fedora Linux 39
KDE Plasma Version: 5.27.9
KDE Frameworks Version: 5.111.0
Qt Version: 5.15.11
Kernel Version: 6.5.10-300.fc39.x86_64 (64-bit)
Graphics Platform: X11
Processors: 12 × AMD Ryzen 5 3600X 6-Core Processor
Memory: 31.2 GiB of RAM
Graphics Processor: AMD Radeon RX 6700 XT
Manufacturer: ASUS

and bluez install info if that helps

Name         : bluez
Version      : 5.70
Release      : 1.fc39
Architecture : x86_64
Size         : 3.4 M
Source       : bluez-5.70-1.fc39.src.rpm
Repository   : @System
From repo    : updates
Summary      : Bluetooth utilities
URL          : http://www.bluez.org/
1 Like

We just published a Common Issue about this:


Oh that’s great, thanks! Looking forward to the patch

Interestingly, I can successfully connect my PS4 controller using bluetoothctl on the command line, but I still fail to pair and connect using the KDE settings module. It fails in the same way, with no specific error message. Once I have it working via bluetoothctl, however, I can disconnect and reconnect with no problems.

All well lol

Running latest Fedora 40 with bluez version 5.76