Gstreamer1-plugins-bad-nonfree installation on Fedora 31 Workstation Multimedia Support


I’m following these instructions to install multimedia support in Fedora:

I have enabled the RPM Fusion repositories:

sudo dnf install$(rpm -E %fedora).noarch.rpm

sudo dnf install$(rpm -E %fedora).noarch.rpm

After doing an dnf update and dnf upgrade run the following (from the above page)

sudo dnf install gstreamer1-libav gstreamer1-plugins-bad-free
gstreamer1-plugins-bad-free gstreamer1-plugins-bad-free-extras
gstreamer1-plugins-bad-freeworld gstreamer1-plugins-bad-nonfree
gstreamer1-plugins-good gstreamer1-plugins-ugly lame-libs lame-libs

I get the following error:

Error: Unable to find a match: gstreamer1-plugins-bad-nonfree

I have been able to install all the other packages individually, but can’t get this one to install.

Please can you help? Thanks

1 Like

I think this quick-docs need to be tweak:

some names changed, this is all What you need:

sudo dnf install gstreamer1-plugins-{bad-\*,good-\*,base} gstreamer1-plugin-openh264 gstreamer1-libav --exclude=gstreamer1-plugins-bad-free-devel

sudo dnf install lame\* --exclude=lame-devel



Thank you @hhlp

I’m new to Fedora, but would like to contribute. Is there a bug tracker for the documentation, or can you get it changed?


Yes, you can definitely contribute! At the upper right hand of every page of the Fedora Docs there is an “Edit this page” button which will allow you to do just that. Here are the steps:

Thanks very much for taking the time to fix problems so that the next person has an easier time. It’s what makes all of this work!

1 Like

for this time I made the changed… waiting for accepting

What I suggest to you, If you would like to contribute, contact Fedora Join Team:

They will guide you and enter a mentoring process and give you a warm welcome to the community:



Thank you @beroset (Nice Transistor by the way!) and @hhlp

Sorry @hhlp

Just came back home and gave it a try and I get:

Error: Unable to find a match: gstreamer1-plugin-openh264

@hhlp I found this. It looks like you have to enable to repository first which I did through Software Centre, and then the install seems to work.


Yes, you have to read Prerequisites


Hi @hhlp

Thanks for the help. I looked through the prerequisites, but it does not mention the need to enable - This text is from the link ‘The openh264 codec is available through the fedora-cisco-openh264 repository that we include by default, but is set to enabled=0. You can either edit /etc/yum.repos.d/fedora-cisco-openh264.repo and edit it to enabled=1’

I did it via the software centre, then clicking on the three vertical dots and clicking repositories, then changing the one marked 'Fedora openh265 (From Cisco) from disabled to enabled. I could then download the package.

May be worth updating the prerequisite notes too?

Outdated documentation… gstreamer1-plugins-bad-nonfree was deleted only in rpmfusion; but not in others thirparty repositories as UnitedRPMs

You only need it…

dnf -y install gstreamer1-{libav,plugins-{good,ugly,bad-free}} --setopt=strict=0
1 Like

@hhlp thanks. Thank you for your dedication. Have a nice day! by simmon