Grub2-mkconfig says dev is not mounted when in chroot while it's mounted

Hello! :slight_smile:

I have quite a serious issue and I honestly think Fedora needs to look into their installer first of all. But beyond that here’s the issue:

I had a Nobara KDE install (which is essentially Fedora 35 for gamers) and I wanted to dual boot wth vanilla Fedora 35 KDE to run some benchmarks. I made some empty space, chose it in the installer and hit “Reclaim Space”'. The installation went superbly and I’m writing from Fedora 35 right now. The problem is that my Nobara Bootloader is gone.

I have tried updating grub and using os-prober. The bootloader just won’t get added to GRUB.

I should mention that Nobara is an encrypted installation.

I decided to just chroot into the system and reinstall/update GRUB in case that would help so I did:

sudo mount --rbind /dev/ /run/media/qushy/fedora_localhost-live/root/dev/
sudo mount --make-rslave /run/media/qushy/fedora_localhost-live/root/dev/
sudo mount -t proc /proc/ /run/media/qushy/fedora_localhost-live/root/proc/
sudo mount --rbind /sys/ /run/media/qushy/fedora_localhost-live/root/sys/
sudo mount --make-rslave /run/media/qushy/fedora_localhost-live/root/sys/
sudo mount --rbind /tmp/ /run/media/qushy/fedora_localhost-live/root/tmp/
sudo mount --bind /run/ /run/media/qushy/fedora_localhost-live/root/run/
sudo chroot /run/media/qushy/fedora_localhost-live/root/

grub2 is getting reinstalled just fine, but when I try to update grub I get:

/usr/sbin/grub2-probe: error: cannot find a device for / (is /dev mounted?).

Any ideas?

Have you solved this? I have the same issue while trying to rebuild grub from a live-usb fedora image, for Fedora 37?

EDIT: I solved looking at this solution about btrfs. Basically I was mounting my partition incorrectly hence that grub config could not be updated.