Grub outputting to integrated graphics, gnome to my dedicated graphics

Hey all, so I got a new GTX 1660 Super, and after installing it on my PC I immediately noticed something was off, because when I tried to boot Fedora I just got stuck on an image of my Motherboard’s logo, which is the first thing that appears when I turn on my PC. After some trial and error I found out that if I try to boot with my HDMI connected to my integrated graphics, I can see the decryption screen just fine, but then after decrypting my disk I should be able to see the login screen, which just stays in a black screen. I can access a tty and then use my system from there, but if I then connect my HDMI back to my GPU after decrypting my disk (going through grub), I can see everything just fine.
I have installed the akmod nvidia drivers and added the DRM modeset to my grub config as per the pinned issue post for nvidia cards, but nothing seems to fix the issue. It’s also worth noting that if I boot with my HDMI connected to my GPU, and then connect it to my MOBA directly, instead of getting a fancy graphical interface to input my passphrase, I get a terminal-like interface. Not sure if that’d help

I’d appreciate any advice, thanks!

Do you have secure boot enabled or disabled.?
If enabled the nvidia modules cannot load unless they are signed and the key enrolled in bios using mokutil.

If the driver does not load it can force a halt in booting.

The first thing I would suggest is to boot into the bios setup and check that secure boot is disabled. See if that makes a difference.

Since you are able to boot and can connect with tty then while in text mode run dmesg | grep -iE 'secure|nvidia' . This is a quick way to find out if the drivers are loading and the status of secure boot. You also can find out the status of secureboot with mokutil --sb-state

There is no way to enable Secure Boot on my bios, and Fedora reports it as disabled.

Please post the output of lsmod | grep nvidia after a new boot.
Also post the output of dmesg | grep -iE 'secure|nvidia' and dnf list installed '*nvidia*'.
Please use the preformatted text tags (on the tool bar above as </>) to retain formatting the same as seen on your screen whenever you post text from your system.

Also, what is the output of efibootmgr?

❯ lsmod | grep nvidia
nvidia_drm             90112  18
nvidia_modeset       1290240  3 nvidia_drm
nvidia_uvm           3219456  0
nvidia              55853056  246 nvidia_uvm,nvidia_modeset
i2c_nvidia_gpu         16384  0
video                  73728  2 i915,nvidia_modeset
❯ dmesg | grep -iE 'secure|nvidia'
[    0.000000] Command line: BOOT_IMAGE=(hd2,gpt2)/vmlinuz-6.2.9-200.fc37.x86_64 root=UUID=0b9d2c2d-f94e-4fcf-8d36-438f92d3de76 ro rootflags=subvol=root rd.driver.blacklist=nouveau modprobe.blacklist=nouveau nvidia-drm.modeset=1 rd.luks.uuid=luks-7bf29126-a7f9-44ba-95b5-38dca615ed04 rhgb quiet rd.driver.blacklist=nouveau modprobe.blacklist=nouveau
[    0.000000] secureboot: Secure boot disabled
[    0.007309] secureboot: Secure boot disabled
[    0.042864] Kernel command line: BOOT_IMAGE=(hd2,gpt2)/vmlinuz-6.2.9-200.fc37.x86_64 root=UUID=0b9d2c2d-f94e-4fcf-8d36-438f92d3de76 ro rootflags=subvol=root rd.driver.blacklist=nouveau modprobe.blacklist=nouveau nvidia-drm.modeset=1 rd.luks.uuid=luks-7bf29126-a7f9-44ba-95b5-38dca615ed04 rhgb quiet rd.driver.blacklist=nouveau modprobe.blacklist=nouveau
[   23.258604] input: HDA NVidia HDMI/DP,pcm=3 as /devices/pci0000:00/0000:00:01.0/0000:01:00.1/sound/card2/input16
[   23.258675] input: HDA NVidia HDMI/DP,pcm=7 as /devices/pci0000:00/0000:00:01.0/0000:01:00.1/sound/card2/input17
[   23.258729] input: HDA NVidia HDMI/DP,pcm=8 as /devices/pci0000:00/0000:00:01.0/0000:01:00.1/sound/card2/input18
[   23.258787] input: HDA NVidia HDMI/DP,pcm=9 as /devices/pci0000:00/0000:00:01.0/0000:01:00.1/sound/card2/input19
[   24.356704] nvidia-gpu 0000:01:00.3: i2c timeout error e0000000
[   25.256819] nvidia: loading out-of-tree module taints kernel.
[   25.256833] nvidia: module license 'NVIDIA' taints kernel.
[   25.268976] nvidia: module verification failed: signature and/or required key missing - tainting kernel
[   25.439724] nvidia-nvlink: Nvlink Core is being initialized, major device number 234
[   25.441334] nvidia 0000:01:00.0: vgaarb: changed VGA decodes: olddecodes=io+mem,decodes=none:owns=io+mem
[   25.489328] NVRM: loading NVIDIA UNIX x86_64 Kernel Module  530.41.03  Thu Mar 16 19:48:20 UTC 2023
[   25.708759] nvidia_uvm: module uses symbols nvUvmInterfaceDisableAccessCntr from proprietary module nvidia, inheriting taint.
[   25.847766] nvidia-uvm: Loaded the UVM driver, major device number 510.
[   26.440202] nvidia-modeset: Loading NVIDIA Kernel Mode Setting Driver for UNIX platforms  530.41.03  Thu Mar 16 19:23:04 UTC 2023
[   26.459542] [drm] [nvidia-drm] [GPU ID 0x00000100] Loading driver
[   27.027207] [drm] Initialized nvidia-drm 0.0.0 20160202 for 0000:01:00.0 on minor 1
❯ dnf list installed '*nvidia*'
Installed Packages
akmod-nvidia.x86_64                                           3:530.41.03-1.fc37                       @rpmfusion-nonfree-nvidia-driver
kmod-nvidia-6.2.9-200.fc37.x86_64.x86_64                      3:530.41.03-1.fc37                       @@commandline                   
nvidia-gpu-firmware.noarch                                    20230310-148.fc37                        @updates                        
nvidia-settings.x86_64                                        3:530.41.03-1.fc37                       @rpmfusion-nonfree-nvidia-driver
xorg-x11-drv-nvidia.x86_64                                    3:530.41.03-1.fc37                       @rpmfusion-nonfree-nvidia-driver
xorg-x11-drv-nvidia-cuda-libs.x86_64                          3:530.41.03-1.fc37                       @rpmfusion-nonfree-nvidia-driver
xorg-x11-drv-nvidia-kmodsrc.x86_64                            3:530.41.03-1.fc37                       @rpmfusion-nonfree-nvidia-driver
xorg-x11-drv-nvidia-libs.i686                                 3:530.41.03-1.fc37                       @rpmfusion-nonfree-nvidia-driver
xorg-x11-drv-nvidia-libs.x86_64                               3:530.41.03-1.fc37                       @rpmfusion-nonfree-nvidia-driver
xorg-x11-drv-nvidia-power.x86_64                              3:530.41.03-1.fc37                       @rpmfusion-nonfree-nvidia-driver
❯ efibootmgr
BootCurrent: 000D
Timeout: 1 seconds
BootOrder: 000D,0011,0000,0003,0002,0008,000A,0005,0007,000B,0006,0009,0004,0001
Boot0000* Windows Boot Manager	HD(1,GPT,3445f45c-af4b-4d60-88cb-f0dc86e51cf1,0x800,0x12c000)/File(\EFI\MICROSOFT\BOOT\BOOTMGFW.EFI)57494e444f5753000100000088000000780000004200430044004f0042004a004500430054003d007b00390064006500610038003600320063002d0035006300640064002d0034006500370030002d0061006300630031002d006600330032006200330034003400640034003700390035007d00000061000100000010000000040000007fff0400
Boot0001* Pop!_OS 21.04	VenHw(99e275e7-75a0-4b37-a2e6-c5385e6c00cb)
Boot0002* pop	VenHw(99e275e7-75a0-4b37-a2e6-c5385e6c00cb)
Boot0003  Hard Drive	BBS(HD,,0x0)0000474f00004e4f95000000010000005b004d006100730073002000530074006f007200610067006500200044006500760069006300650000000501090002000000007fff040002010c00d041030a000000000101060000140305060007007fff040001042e00ef47642dc93ba041ac194d51d01b4ce631003200350043003200300031003000300037003200360000007fff04000000424f00004e4fab000000010000006f005700440043002000570044003100300045005a00450058002d00300030004b00550057004100300000000501090002000000007fff040002010c00d041030a0000000001010600001703120a000000ffff00007fff040001043e00ef47642dc93ba041ac194d51d01b4ce62000200020002000570020002d00440043005700310043003700530036003200300030003000300000007fff04000000424f00004e4faf000000010000006f005700440043002000570044005300310032003000470032004700300041002d00300030004a0048003300300000000501090002000000007fff040002010c00d041030a0000000001010600001703120a000200ffff00007fff040001043e00ef47642dc93ba041ac194d51d01b4ce63900310032003400450043003000380038003100390033002000200020002000200020002000200000007fff04000000424f
Boot0004* Pop!_OS 21.04	VenHw(99e275e7-75a0-4b37-a2e6-c5385e6c00cb)
Boot0005* Linux Boot Manager	VenHw(99e275e7-75a0-4b37-a2e6-c5385e6c00cb)
Boot0006* Linux Boot Manager	VenHw(99e275e7-75a0-4b37-a2e6-c5385e6c00cb)
Boot0007* endeavouros-5377	VenHw(99e275e7-75a0-4b37-a2e6-c5385e6c00cb)
Boot0008* endeavouros-2082	VenHw(99e275e7-75a0-4b37-a2e6-c5385e6c00cb)
Boot0009* Garuda	VenHw(99e275e7-75a0-4b37-a2e6-c5385e6c00cb)
Boot000A* Linux Boot Manager	VenHw(99e275e7-75a0-4b37-a2e6-c5385e6c00cb)
Boot000B* Linux Boot Manager	VenHw(99e275e7-75a0-4b37-a2e6-c5385e6c00cb)
Boot000D* Fedora	HD(1,GPT,3445f45c-af4b-4d60-88cb-f0dc86e51cf1,0x800,0x12c000)/File(\EFI\FEDORA\SHIMX64.EFI)
Boot0011* Fedora	HD(1,GPT,3445f45c-af4b-4d60-88cb-f0dc86e51cf1,0x800,0x12c000)/File(\EFI\FEDORA\SHIM.EFI)0000424f

Huh, that’s interesting. Somehow I can see my previous Linux and Windows installs from years ago. Wonder how they’re still there

In the past we have seen issues with an excess of entries in the uefi responses to efibootmgr.

The common fix may have been for the user to remove the unnecessary entries using efibootmgr. For example, to remove the entry for Boot0004 the command would be efibootmgr -B 0004 which would remove that one entry from the boot list.

I suggest trying to remove all but the current windows and fedora entries simply as a housekeeping task then try again to see if the boot progresses differently. Unless there is a reason to keep them that would mean removing all the entries 0001 thru 000B for a start.

Tried running the efibootmgr -B command. It always gives me an error saying that I must specify an entry to delete, despite the 0001 I inserted

After running efibootmgr -B NNNN you could use the efibootmgr command to verify whether the specified entry exists or not.

I think you can only remove one entry at a time with that command, and will give that error if the specified entry does not exist.

Ended up deleting the entries with another command, but the issue persists.