Grub-mkconfig: command not found installing grub themes

I’ve already tried to install grub themes, in three cases the ‘grub-mkconfig’ error occurred, does anyone know how I solve these problems? Errors below:

1-Attempt to install grub theme name Atomic-GRUB-Theme, displays the information: Command 'grub-mkconfig' not found

[jack@fedora Atomic-GRUB-Theme]$ sudo ./ [sudo] password for jack: Yes, You are root! ==> Downloading files… Cloning into ‘/tmp/Atomic-GRUB2-Theme’… remote: Enumerating objects: 196, done. remote: Counting objects: 100% (35/35), done. remote: Compressing objects: 100% (34/34), done. remote: Total 196 (delta 18), reused 7 (delta 1), pack-reused 161 Receiving objects: 100% (196/196), 115.95 KiB | 4.46 MiB/s, done. Resolving deltas: 100% (77/77), done. ==> Copying files… You must set the theme in your GRUB config file, Would you like to do it now? [y/n]

==> Applying changes… ./ line 7: grub-mkconfig: command not found → Theme successfuly applied! → Restart your PC to check it out. [jack@fedora Atomic-GRUB-Theme]$

2 -Attempt to install grub theme name primitivistical-grub-v0.2, displays the information: Command 'grub-mkconfig' not found

[jack@fedora primitivistical-grub-v0.2]$ sudo ./ Command ‘grub-mkconfig’ not found [jack@fedora primitivistical-grub-v0.2]$

3 - Attempt to install grub theme name steamos-1080p, displays the information: Command 'grub-mkconfig' not found

[jack@fedora steamos-1080p]$ sudo python3 -i [sudo] password for jack:

 ___ _ __ __ _ _
| \ __ _ _ _| |__ | \/ |__ _| |_| |_ ___ _ _
| |) / _` | '_| / / | |\/| / _` | _| _/ -_) '_|
|___/\__,_|_| |_\_\ |_| |_\__,_|\__|\__\___|_| GRUB THEME

Written by Vandal (VandalByte)


($) Copying assets to /boot/grub/themes//darkmatter done.

($) Editing the GRUB file … done.

($) Updating GRUB …

/bin/sh: line 1: grub-mkconfig: command not found

(#) Dark Matter GRUB theme has been successfully installed !!

[jack@fedora steamos-1080p]$

Grub-mkconfig is not a fedora command we use grub2
You can follow this instructions


I have no grub directory in my /boot, it is grub2. It seems the tutorial you followed is outdated.

1 Like

Follow instructions from here.

1 Like

In general, any time you try to install a grub theme on newer fedora systems you must review the install script and make certain it is properly constructed to use the fedora grub directory tree. If it looks like it might alter the /boot/efi/EFI/fedora/grub.cfg file then it is definitely wrong and must be changed to only alter the /boot/grub2/grub.cfg file.


This grub theme I can, but what I want is to install this:

The tutorial that followed was the one described on this site:

Now I understand, I did the grub removal and reinstallation procedure, I tried to install the grub theme, changing the installation python script in grub-mkconfig to grub2-mkconfig and even then, I was not successful, when rebooting and starting , does not display grub theme:

I don’t know what else I can do to install this grub themm Dark Matter GRUB Thema, an error ended up occurring and I lost the Operating Systems that were displayed in grub: Pop-OS 22.04 LTS and Windows 11, is there any tip from you to be able to recover and re-display in grub?

[jack@fedora ~]$ sudo grub2-mkconfig -o /boot/grub2/grub.cfg
[sudo] password for jack:
Generating grub configuration file...
Theme found: /boot/efi/EFI/fedora/themes/dell-/theme.txt
Linux image found: /boot/vmlinuz-5.19.6-200.fc36.x86_64
Found initrd image: /boot/initramfs-5.19.6-200.fc36.x86_64.img
Linux image found: /boot/vmlinuz-5.19.4-200.fc36.x86_64
Found initrd image: /boot/initramfs-5.19.4-200.fc36.x86_64.img
Linux image found: /boot/vmlinuz-5.18.19-200.fc36.x86_64
Found initrd image: /boot/initramfs-5.18.19-200.fc36.x86_64.img
Linux image found: /boot/vmlinuz-0-rescue-22df1cd485c84a3f97771273e2ddbe69
Found initrd image: /boot/initramfs-0-rescue-22df1cd485c84a3f97771273e2ddbe69.img
Adding menu entry for UEFI Firmware Settings...
[jack@fedora ~]$

try sudo cat /boot/efi/EFI/fedora/grub.cfg and post the results here.

[jack@fedora ~]$ sudo cat /boot/efi/EFI/fedora/grub.cfg
[sudo] senha para jack: 
search --no-floppy --fs-uuid --set=dev c90ade05-fe98-47ce-abbb-1c9666d70344
set prefix=($dev)/boot/grub2
export $prefix
configfile $prefix/grub.cfg
[jack@fedora ~]$

That looks right, so not an issue from that file.

What is the output of ls /boot/efi/EFI? The other OSes should have their efi files there as well, like this.

$ sudo ls /boot/efi/EFI
[sudo] password for USER: 
Boot  fedora  Microsoft

You can see the Microsoft directory there with its boot loader info.

[jack@fedora ~]$ sudo ls /boot/efi/EFI
[sudo] password for jack:
BOOT Dell fedora
[jack@fedora ~]$

  1. Do you have 2 or more drives?

  2. Does windows have a separate efi partition?
    lsblk -o NAME,PATH,PARTTYPE,MOUNTPOINT,FSTYPE should show all the devices and partitions.

  3. What is the content of /boot/efi/EFI/Dell?

  4. If you read the instructions linked in post #3 above you would know that the directory /boot/efi/EFI/fedora/themes is the wrong location. That explicitly says that the directory is /boot/grub2/themes. You should remove the one under /boot/efi.

1 Like