Gnome Software not working in Fedora Silverblue 36 with “Your operating system is no longer supported...” message

The GNOME Software application appears to have lost its repository configuration. I recall, from the fedora 36 release notes, that package configuration has moved from /var to /lib and I wonder if it’s related to that. The problem seemed to arise with gnome-software-42.1.

Until the problem is fixed you can update your flatpaks with “flatpak update” and your OS image and layered packages with “sudo rpm-ostree upgrade” in a terminal.

1 Like

I did my rpm-ostree upgrade in the terminal, and that went fine, but my GNOME Software is not working, just like the others in this thread:

I have the same issue. Just rebased from 35 to 36, and got this window:

1 Like

I just rebooted and got that exact same error too. Is there some issue or thread where to track progress of this? Not being able to add/remove/update software (graphically) is not nice :frowning_face:

1 Like

I get the same error… I’m kinda new to silverblue so I was thinking I’ve done something wrong but it seems to be broken everywere…

I guess It will be fixed soon… Until then just uptade with rpm-ostree upgrade and flatpak update and well installation are also in CLI I guess until there is a fix.

1 Like

I’ve found a temporary “workaround”:
sudo chmod 757 /var/cache/rpm-ostree/solv/

This gives everyone write access to this directory, whereas it used to be limited to root. Do this at your own discretion and accept the possible risks that comes with that.

This looks to be the best place to track it for now:

Edit: Note that rpm-ostree upgrade command is unaffected. So if you want to, you can use the command line to manage your system instead of the GUI in the meantime.


Thanks for the bug report link. Now we can follow along as this gets fixed.

Thanks. There it also explains the workaround we can apply as this gets fixed:

rpm-ostree override replace
systemctl reboot

Thanks for the tip. But as you warned, perhaps is better to keep using the command prompt for the time being and keep security in place.

Yep, I can confirm this command works. It downgraded the offending library and now all seems back to normal, after a reboot of course.

The fix has been moved to stable:

To get it, just do a regular rpm-ostree update in the terminal:

$ rpm-ostree update
$ systemctl reboot

When the system rebooted, my GNOME Software was working.

I think I need to wait a little bit. Just did an update and the issue remains. :slightly_frowning_face:
Perhaps I did something wrong. This is the output I get, either using rpm-ostree update or rpm-ostree upgrade:

rpm-ostree upgrade
2 metadata, 0 content objects fetched; 788 B transferred in 2 seconds; 0 bytes content written
Inactive base replacements:
Inactive requests:
  fedora-workstation-repositories (already provided by fedora-workstation-repositories-35-3.fc36.noarch)
Checking out tree 37a0304... done
Enabled rpm-md repositories: fedora-cisco-openh264 fedora-modular updates-modular updates fedora rpmfusion-free-updates-testing rpmfusion-free rpmfusion-nonfree-updates-testing rpmfusion-nonfree updates-testing updates-archive
⠁ Updating metadata for 'fedora-cisco-openh264'   0% [░░░░░░░░░░░░░░░░░░░░] (0s)⠙ Updating metadata for 'fedora-cisco-openh264'  95% [███████████████████░] (0s)⠚ Updating metadata for 'fedora-cisco-openh264' 100% [████████████████████] (0s)Updating metadata for 'fedora-cisco-openh264'... done
Updating metadata for 'fedora-modular'... done
Updating metadata for 'updates-modular'... done
Updating metadata for 'updates'... done
Updating metadata for 'fedora'... done
⠁ Updating metadata for 'rpmfusion-free-updates-testing'   0% [░░░░░░░░░░░░░░░░░⠙ Updating metadata for 'rpmfusion-free-updates-testing'  95% [█████████████████⠚ Updating metadata for 'rpmfusion-free-updates-testing' 100% [█████████████████Updating metadata for 'rpmfusion-free-updates-testing'... done
Updating metadata for 'rpmfusion-free'... done
⠁ Updating metadata for 'rpmfusion-nonfree-updates-testing'   0% [░░░░░░░░░░░░░░⠙ Updating metadata for 'rpmfusion-nonfree-updates-testing'  95% [██████████████⠚ Updating metadata for 'rpmfusion-nonfree-updates-testing' 100% [██████████████Updating metadata for 'rpmfusion-nonfree-updates-testing'... done
Updating metadata for 'rpmfusion-nonfree'... done
Updating metadata for 'updates-testing'... done
Updating metadata for 'updates-archive'... done
Importing rpm-md... done
rpm-md repo 'fedora-cisco-openh264'; generated: 2022-04-07T16:52:38Z solvables: 4
rpm-md repo 'fedora-modular'; generated: 2022-05-04T21:12:01Z solvables: 825
rpm-md repo 'updates-modular'; generated: 2022-05-08T01:14:17Z solvables: 862
rpm-md repo 'updates'; generated: 2022-05-13T01:50:57Z solvables: 7930
rpm-md repo 'fedora'; generated: 2022-05-04T21:16:11Z solvables: 67992
rpm-md repo 'rpmfusion-free-updates-testing'; generated: 2022-05-13T10:08:26Z solvables: 12
rpm-md repo 'rpmfusion-free'; generated: 2022-05-04T04:48:11Z solvables: 506
rpm-md repo 'rpmfusion-nonfree-updates-testing'; generated: 2022-05-13T10:33:46Z solvables: 3
rpm-md repo 'rpmfusion-nonfree'; generated: 2022-05-04T05:11:55Z solvables: 225
rpm-md repo 'updates-testing'; generated: 2022-05-14T02:04:01Z solvables: 15678
rpm-md repo 'updates-archive'; generated: 2022-05-14T03:31:43Z solvables: 7681
Resolving dependencies... done
No upgrade available

Not sure if this is related, but now GNOME Software is working again, but this update of the RPMFusion repos persists. Updating via GNOME Software doesn’t apply it, and it doesn’t show when doing rpm-ostree update:

I tried to remove the “old” RPM Fusion repos and then reinstall, but that didn’t work. Terminal output was that ffmpeg and ffmpeg-libs were unavaliable.

To fix what I broke, I rolled back to my previous version:

$ rpm-ostree rollback

I checked on ffmpeg and I am running the latest version, so all good for now.

Side-note, as I guess may be related and you still have that “harder” setup: You can simplify rpmfusion updates, like to Fedora 36 a lot, so you don’t need to uninstall and reinstall the rpmfusion repos etc. (That may also fix your upgrade issue there.)

Thank you @rugk!! I will try it.

1 Like

I had to modify the code from Fedora Discussion so it works for Fedora Silverblue 36 users who upgraded from 35.

Before you run the command, confirm the version of the RPM Fusion repos you need to uninstall by running:

rpm-ostree status

Once I did that, I knew how to modify this code before running it in the terminal:

rpm-ostree update \
            --uninstall rpmfusion-free-release-36-0.2.noarch \
            --uninstall rpmfusion-nonfree-release-36-0.2.noarch \
            --install rpmfusion-free-release \
            --install rpmfusion-nonfree-release

After a reboot, this cleared up the issue with RPM Fusion repo updates in GNOME Software.

1 Like

I applied this but still Gnome-software doesn’t work. This is what I get now:

I was able to fix my issue following comment #24, here:

That fixed one problem for me, but now I have 2088878 – Silverblue: Failed to create file ?/var/run/dnf-metadata.lock.9ONHM1?: Permission denied and still I cannot use gnome-software. I also get 2088879 – rpm-ostree update gets stuck when using rpm-ostree by terminal.

So, basically, I cannot update. No way. :sob: