Gnome Software Center Updates Error

When attempting to see the updates tab in the software center, I receive the error message shown in the attached image. These problems started occurring after I installed the NVIDIA driver + Control Panel using the commands shown here: [ Howto/NVIDIA - RPM Fusion ] It’s worth noting that I first tried to install them from the software center automatically first, but then uninstalled them because they did not work.

Any help with this problem is much appreciated.

1 Like

What if you perform the updates from the command line?

sudo dnf update

Do you receive any dependencies error?


I receive the following error:

Additionally, this error message occasionally appears when I log in to my account. I’m not really sure what determines whether or not it appears, but I know it’s related to the NVIDIA drivers and I know that it started happening at the same time as the store problem.

I have also checked the directory [ /etc/dnf/protected.d ] to see if “kernel” was listed as protected, but it was not. I’m really not sure why [ dnf update ] fails as shown.

The kernel is a protected package by default, I think.
Btw sorry, but personally I can’t be of help.

You could explore dnf distro-sync, but I don’t guarantee.

1741381 – DNF wants to remove kernel-core suggest that you try: ‘sudo dnf mark install kernel kernel-modules’ that would tell dnf that you specifically had, as a user, requested the kernel and kernel-modules packages, so that solutions it find, should keep them.

Unfortunately, the command [ dnf distro-sync ] returns the same “would remove the kernel” error as the others. I tried [ sudo dnf mark install kernel kernel-modules ] as well, and the command completed successfully, but made no difference in the result of [ dnf update ] or [ dnf distro-sync ].

hum… ‘sudo dnf mark install kernel-core’ ?

Same result as [ sudo dnf mark install kernel kernel-modules ].

A side note, I can still install and remove packages from the store, I just can’t check for updates. I’ve also tried completely removing and reinstalling all NVIDIA-related packages, but to no effect.

What if you try to add verbose flags to dnf?
sudo dnf update -vvv

Here is the result:

The command stops right after dependency resolution, which I’m guessing explains the store’s message, depsolve transaction.

Have you tried …

dnf clean all before running the update command?

You can use sudo dnf repoquery --unsatisfied to display broken dependencies. May be worth a try.

Finally, I would issue a sudo rpm --rebuilddb to rebuild the rpm database. That may fix your problem.

I just tried both [ dnf clean all ] and [ sudo rpm --rebuilddb ], but the terminal shows the same error. After running [ sudo dnf repoquery --unsatisfied ] with the [ --verbose ] option added to the end, I got this:

The only errors seem to be in the fedora-updates-modular repo, which would explain what’s happening.

Next thing to do is disabling all unused (modular?) and all third-party (adobe, skype, :frowning_face:) repos and the-run above commands.

Well… playing apprentice wizard: maybe --noautoremove

I tried both commands, but the repoquery gave the same result and the system still won’t update. I’m thinking I may need to completely remove and replace the [ fedora-updates-modular.repo ] file in the [ /etc/yum.repos.d ] folder. How would I go about safely doing so?

I’d like to know the output of “sudo dnf repoquery --whatconflicts kernel-core”.

To safely deactivate some repositories, I think I would launch gnome-software, in upper-right click the icon with horizontal lines, click software repositories, and deactivate one/some repositories. So that you could easily re-“Enable” them later.

Seems to give the same result as the [ sudo dnf repoquery --unsatisfied ] command: