GNOME doesn't work with VPNs (Fedora 38)

All GNOME internet apps (Epiphany, Weather, Maps, ecc.) don’t work when VPN is active (other internet apps work). The issue affects both OpenVPN and Wireguard connections. Fedora 38.

I’m unable to reproduce the problem, i.e. it works for me on a Fedora 38 client.
I use WireGuard running in dual-stack mode on a Fedora 38 Linode hosted in the London DC.

Try using a different endpoint, make sure to disable proxy, use a public DNS resolver.
Verify that both IPv4 and IPv6 are routed to the VPN, check and


Thank you for your support. I think I fixed it. There were some issues with IPv6 settings and managing DNS servers in IPv4. It seems that by setting the DNS server to automatic the VPN’s DNS server is not used (it uses internet provider’s DNS). Setting it manually solves the issue.