Gnome 46 not working with 390xx Nvidia Legacy drivers

I’ve currently updated my fedora 39 to fedora 40 and Gnome to 46 with it. The problem I am facing is the texts aren’t visible. When I uninstalled my whole Nvidia drivers, the problem goes away.
I’m on x11 and as reddit users suggested I add GSK_RENDERER=gl to /etc/environment
This is the problem I am facing:

Is this the solution? Or are you looking for an other one?

No it is not. apperently it works for 470xx Nvidia legacy drivers not mine. I just mentioned it so it may help identifying the problem easier

1 Like

Also facing the same issue

Found a solution here - Gnome Issue after Update to Fedora 40 - #17 by babam

TLDR - add export GSK_RENDERER=gl to your .bash_profile and log out/in; this worked for me anyway.

Not a great solution because I’d rather not add cruft to my .bash_profile, but there it is.

I tried adding it to ~/etc/environment but it doesn’t work

If you put it in /etc/environment don’t use export - then it’ll work.

Also ~/etc/environment isn’t a thing; I’m assuming you meant /etc/environment

Yes my bad. I’ve tried everything.
I also tried adding it to .bash_profile but nothing seems to work :((

Probably you just miss some packages. Have a look if they are still installed/available on F40:

How to check if any packages are missing?

sudo dnf list gtk-murrine-engine

   Available Packages
   gtk-murrine-engine.x86_64                                  0.98.2-29.fc40                                   fedora

sudo dnf list /*gnome-themes*

   Installed Packages
   gnome-themes-extra.x86_64                                   3.28-19.fc40                                   @fedora

If it says available, you can install it.
If it is written installed you are good to go