Fujitsu FMV UH-X inbuilt microhone not working in Fedora 39 - Intel Raptor Lake-P/U/H

I have recently procured a Fujitsu FMV UH-X 2in1 laptop. After installing Fedora 39, I discovered that the inbuilt microphone does not work. However, if I connect a headphone then the microphone works through it.
Here is my output of inxi -Fzxx for audio device:

Audio:
Device-1: Intel vendor: Fujitsu Client driver: N/A bus-ID: 00:05.0
chip-ID: 8086:a75d
Device-2: Intel Raptor Lake-P/U/H cAVS vendor: Fujitsu Client
driver: sof-audio-pci-intel-tgl bus-ID: 00:1f.3 chip-ID: 8086:51ca
API: ALSA v: k6.5.11-300.fc39.x86_64 status: kernel-api
Server-1: JACK v: 1.9.22 status: off
Server-2: PipeWire v: 0.3.84 status: active with: 1: pipewire-pulse
status: active 2: wireplumber status: active 3: pipewire-alsa type: plugin
4: pw-jack type: plugin

======================

Any suggestion to get the inbuilt microphone to work? Thanks.

As a fellow UH-X user, the solution from Suggestions before filing an SOF bug — SOF Project 2.7.0 documentation works for me

Specifically adding

options snd_sof_intel_hda_common dmic_num=4
to
/etc/modprobe.d/alsa-base.conf
and restarting the system.

Thanks for your reply, It does help!

I just updated my kernel to 6.6.3 and the sound system has a proper driver for Intel Raptor Lake - P/U/H and the sound system is working nicely

Hi,
I’m on fedora 40 with the file:

➜ cat alsa-base.conf
options snd_sof_intel_hda_common dmic_num=4

and the microphone doesn’t work.

I’ve the same sound card in a dell 9440 laptop.

Can someone help?

Best Regards,