Flatpak 'Fedora Platform'

Hello, peeps.

I ran flatpak list and found that I seem to have Fedora Platform org.fedoraproject.Platform 32 f32 fedora system installed instead of the f33.
I have tried googling, but found nothing of interest. flatpak update doesn’t seem to help, either.



This is the runtime for the fedora flatpak repo. I believe it was initially built for an immutable system like silverblue, but it also gives you access to flatpaks following fedora’s packaging guidelines, or just a simple way to get flatpaks without adding flathub. flatpak remote-delete fedora will remove it and any apps unstalled under it.


Thanks. Ok, so it there is no way to update it to f33?

Runtimes are like dependencies for packages. Flatpak Concepts

Flatpaks can have multiple versions of the runtimes installed depending on what the applications require.

To list applications that are used by a specific runtime:
flatpak list --app --app-runtime <runtime>
for example:
flatpak list --app --app-runtime org.gnome.Platform

To remove runtimes that are no longer used
flatpak uninstall --unused



Thanks :blush:

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.