Fix overscanning when using TV as a second monitor

Greeting everyone. I’m using a 42" Panasonic Viera Plasma TV as a second monitor and the output on that screen is bigger than the TV so I get a cropped view of my computer. I have seen some ways to change it on X11

xrandr --output screen-name --scale 0.8x0.8

as well as enabling fractional scaling, though they are not doing what I want.
I mostly use wayland as a display server so I’m wondering if there is a way to make the output on the TV shrink so it can fit my TV?

This is the information of my TV when typing xrandr --query

DP-3 connected 1920x1080+0+0 (normal left inverted right x axis y axis) 0mm x 0mm
   1920x1080     59.96*+
   1440x1080     59.99  
   1400x1050     59.98  
   1280x1024     59.89  
   1280x960      59.94  
   1152x864      59.96  
   1024x768      59.92  
   800x600       59.86  
   640x480       59.38  
   320x240       59.52  
   1680x1050     59.95  
   1440x900      59.89  
   1280x800      59.81  
   1152x720      59.97  
   960x600       59.63  
   928x580       59.88  
   800x500       59.50  
   768x480       59.90  
   720x480       59.71  
   640x400       59.95  
   320x200       58.96  
   1600x900      59.95  
   1368x768      59.88  
   1280x720      59.86  
   1024x576      59.90  
   864x486       59.92  
   720x400       59.55  
   640x350       59.77  

Thanks in advance and if I should give more information let me know.

Sometimes the TVs have “zoom” settings to fix that sort of thing. You might want to check if yours has such an option. It would probably be easier to fix the problem that way.

Otherwise, it looks like you could add those margins by specifying something like the following on the kernel command line[1] (the m at the end adds 1.8% margins to the x and y axis[2]).

video=DP-3:1920x1080m

  1. https://wiki.archlinux.org/title/kernel_mode_setting#Forcing_modes ↩︎

  2. https://cgit.freedesktop.org/nouveau/linux-2.6/tree/Documentation/fb/modedb.txt ↩︎

I can’t quite tell what you’re trying to do.

I think you are trying to make a monitor be a replica of a different resolution monitor by adjusting its scaling.

I don’t know whether that should work. I haven’t done much with setting up monitors as replicas. But I do know some things don’t work if you make one monitor a replica of another that do work if you extend the desktop across the two monitors then position them so the entirely overlap. In that mode, having different scaling between the two does work in Wayland.
Depending on your choice of desktop software, there may then be some side issues with the taskbar. But those also can be dealt with.

Yeah the TV does have a zoom setting but it doesn’t make it fit correctly. I added the line you provided and I think it did improve a little bit I’ll keep trying and let you know.

You might need Mm instead of just m (the captital m uses CVT timing calculations). Also, verify that DP-3 is the correct name for the connection by verifying it shows up in the output of ls /sys/class/drm.

I’m trying to add like a padding so the output is not bigger than to screen and doesn’t crop the content. Like in that drawing I just made, make the red fit in the blue haha. The red is how the output is and the blue is the TV screen.

1 Like

So you’re trying to compensate for the TV’s overscan. Ideally, you’d put the TV in ‘1:1’ or ‘Just Scan’ mode, but that’s not available on many older TVs.

GNOME has an “Adjust for TV” option in its Display settings, but it’s hardware-dependent. KDE appears to have something similar when in a Wayland session. In an X session, I think you could use xrandr --set underscan on.

Yes, that’s the actual problem. An overscan. I read that the way to fix it is by using

xrandr --output <output_name> --transform 1.0,0,<shift_value>,0,1.0,<shift_value>,0,0,1.0

and playing with the shifting values.

On Plasma Wayland overscanning and fractional scaling work very well, do you need X11?

Might be one of the many things making people switch to Wayland

I have occasionally run into the overscanning issue with using a tv as a monitor.
Usually the tv has its own setting to configure that and it is not done from fedora.

I had to dig into the settings on a couple different TVs to find it when it cropped up for me.

For my current TV I used the settings Picture → aspect ratio – and turned on just scan to fix this problem. I am using a 4k LG TV at present for my monitor. The same was needed for my earlier Samsung TV.