Fedora Silverblue 39 Hibernation?

Is there any significant difference in configuration of hibernation on Fedora Silverblue 39 compared to Fedora Workstation 39?

Multiple online tutorials describe this process for F39 Ws as following:

  1. Make a swap partition with enough space to store whole RAM and ZRAM, add it to fstab
  2. Patch the initramfs to include resume module with dracut
  3. Add resume line with UUID of a swap partition to GRUB_CMDLINE_LINUX, make config
  4. Test the hibernation with systemctl hibernate

But at least some of the changes affect files managed by OSTree.

So what sould I do to properly configure hibernation on Fedora Silverblue 39?

When I’m trying to follow this guide, on step 11 I’m getting an error Call to Hibernate failed: Not enough swap space for hibernation.

I have 32 GiB of RAM and 8GiB of ZRAM, which requires somewhere around 48GiB of swap. I am creating a /var/swap/swapfile with size of 56GiB, which should be enough. Don’t know what I could debug exactly and could use a hint.

System properties:

  • Fedora Silverblue 39
  • Root is encrypted with LUKS, but that shouldn’t be the issue
  • Secure Boot is disabled

Hello! Was solved?


The hibernation itself is a complicated topic in Fedora now.

You can read the discussion here.

1 Like

The question is, was your issue solved? If so, how did you solve it?

Sadly, no, not yet at least. Had no luck finding a solution nor experimenting myself.

I also opened a question on StackOverflow regarding hibernation on recent Fedora releases in case somebody wants to follow this.

1 Like