Fedora on i5 10400 (UHD graphics)

I’ve been trying to load F33 on a machine with an intel i5-10400 processor (UHD graphics) on an Asus Z590 mother board. The video only works in Gnome xorg mode. I have to run the install from Basic Graphics mode. After the install and setup, the option to run Gnome (Wayland) is not shown during login. Is this a known problem?

I also tried this with Branched F34 RC 1.1 with the same results. I don’t have the PC handy now so I can’t try things.

Is anyone successfully running on an intel i5 10400?

normally you should see a “gear wheel” A-F-T-E-R you keyed in your user name at the graph. login prompt.
clicking on it …

there is a thread [1] in this forum with similar problems running a newer CPU/GPU => only “basic graphic mode”
named “F33 and UHD Graphics 630”

I am used to the gear wheel. it usually displays Gnome, Gnome-xorg, and Gnome-Classic. The Gnome option sets a Wayland session. That option doesn’t even show up. It’s looking like Wayland is not compatible with the UHD graphics CPUs.

I’ve kept the Intel i5-10400 processor, but exchanged the ASUS Z590-A mother board for an MSI MPG Z490 motherboard. This runs Wayland and X11 sessions fine. After I installed F33 from my thumb drive the motherboards Realtek wired network didn’t work; so I installed an intel based network card. That connection worked fine; so I ran the six months worth of updates. after that and reboot I found that the Realtek network connection worked fine.