Fedora memory management

This may seem an odd question, (and if this is the wrong place to ask please move the thread), but here goes. When doing development or data work with Debian or Ubuntu I would with some regularity get system freezes on my not-so-powerful lappy and have to hard reboot. In Fedora I get freezes too, but it always manages to recover without needing to reboot. I guess this is related to kernel config differences or patching.

I never had a compelling reason to investigate since I love Fedora. But I’ve recently been using NixOS (I hear the cry of the configuration file :wink: and am experiencing the hard and enduring freezes as before, so now I’m really curious.

I haven’t messed with kernel building in a long time. I did it regularly long ago, but with Slackware which always shipped the vanilla kernel. I can look at the kernel configuration in Fedora myself, but have no clue how to track down the rest of the optimisations implemented by Fedora. If someone could point me in the right direction I’d appreciate it. (I have a feeling it’s more than just kernel configuration, but could be wrong.)

Thanks for listening.

Have you tried using a matching zram configuration on Nixos?

Fedora uses systemd-oomd, a userspace out-of-memory (OOM) killer, along with zram. I’m not sure about Debian, Ubuntu or NixOS use any OOM management solution.

I can try.

This sounds promising, thank you. There is a Nixos option to enable it.

EDIT:
It appears it is enabled by default, but systemd.oomd.enableUserSlices wasn’t, so I tried that…I’ll let you know if it helps.

1 Like

Last time I did get freezes it was on Ubuntu but none of my Fedora-based laptops ever got into that issue. Something that did help me was I could not find anything explaining the isuse in the system logs, because the machine did froze before the log could get there.

I did find out by configuring my logs to be uploaded to another laptop and it helped me find out what was happening on the laptop that liked to get into freezing.

For this, I did install and use Sytemlog-NG to send all logs from that Dell to a Lenovo and investigate.

Hope this might help.

Thanks. enableUserSlices had no effect. I’m going to try enabling zram.

BTW, I appreciate everyone’s tolerance since this is really off-topic for this forum. :slight_smile: