Fedora Linux kernel update breaks NVIDIA driver


It seems the kernel update kernel-5.17.5-200.fc35.x86_64 breaks NVIDIA driver akmod-nvidia. After kernel update on Fedora 35, the the driver falls back to neuveau, and the session type defaults back to Wayland.

It seems booting into an earier kernel kernel-5.17.4-200.fc35.x86_64 from GRUB resolves the issue. As I spent a couple of hours finding out what caused the problem, I thouhght it was worth sharing here, so that it may help someone.

I’m on Fedora 35, and will update once version 36 final is out (probably next week). I expect the issue will be present also on version 36, since it’s kernel-related.

Maybe your GPU is now out of the latest (unnumbered) driver release.
Try to install the latest numbered version, I think is the 470 from RPMFusion, anyway do a search with dnf.
I faced the same problem after updating and that was the solution.

You might also try dnf reinstall akmod-nvidia and see if it builds the driver with the new kernel.

1 Like

With earlier releases of fedora the nvidia driver could only be activated with secure boot disabled. Is that the case here?
You can tell with dmesg | grep -iE 'nvidia|secure'

Also, you can tell what nvidia driver is installed with dnf list installed akmod-nvidia. The current release is 510.60 for fedora 35 and will soon be updated to 510.68 after 36 is released and you upgrade.

If you are still running the 470 driver then you need to know what nvidia card you have before updating to the latest since the nvidia upgrade from 470 to 495 and beyond dropped support for some of the earlier cards.

1 Like


Thanks for all your tips! I tried the suggestions, but it still doesn’t work. This is what I found:

  • I did dnf remove akmod-nvidia, and then dnf install akmod-nvidia, but it still failed to load.
  • Secure boot is disabled.
  • The current NVIDIA driver installed is 510.60.02-1.fc35.

How can I find out if I run the 470, or the 495 driver?

I found a recent thread, that might be related: https://discussion.fedoraproject.org/t/how-to-load-nvidia-driver-with-secure-boot-enabled-on-fedora-36/75807

I might upgrade to Fedora 36 next week first, and see if that resolves the issue. Or do you think I should rather fully resolve this issue on Fedora 35, in order to successfully upgrade to 36?


Hi, so what Nvidia card does your machine have?
My last gen rtx 2060 (from 2019) running the akmod-nvidia drivers hasn’t experienced any issues lately, so it may be as suggested above, that your card fell out of favor with nvidia.

You can run nvidia-smi when the proprietary driver is active for driver info.

1 Like


Thanks @lampahojd for the info: that’s stange though, as I’ve GeForce RTX 2060 SUPER, which must be very similar in this regards.

nvidia-smi also outputs the 510.60.02 driver version; I was just confused by the 470, and 495 versions others referenced above, (The point is, that my card passed those old versions: sorry for my confusion.)

To fully remove the nvidia driver a simple sudo dnf remove *nvidia* followed by a reboot will remove it.

Then a new sudo dnf install akmod-nvidia will reinstall it and should ensure the drivers are properly compiled and functional.


Thanks @computersavvy for the detailed description, however I did exactly like that – I didn’t miss the reboot step. (Sorry I didn’t add this to my list.)

As far as I know, Fedora 36 will come out tomorrow, so that I’ll test on the new system very soon, and let you know how the NVIDIA driver worked.


I can’t seem to get the NVIDIA driver working with the updated kernel kernel-5.17.5-200.fc35.x86_64, none of the above suggestions worked. The issue is present accordingly to the thread-starting post.

In-between the Fedora version 36 came out. Do you think I should just proceed with the updade from e.g. Gnome Software (maybe when I booted into the previous kernel-5.17.4-200.fc35.x86_64, that perfectly works), and expect this issue ‘magically’ being resolved during the process? I’m afraid, that if NVIDIA driver doesn’t work with the updated kernel kernel-5.17.5-200.fc35.x86_64, than neither it will work with Fedora 36 (which might also run on the same new kernel, I guess). It’s a machine I use in production, so I can’t just try and see.

Do you think there anything else I could try to get NVIDIA driver working with the above kernel? To wrap up, secure boot is disabled, reinstalling (tried in multiple ways) akmod-nvidia doesn’t resolve the issue, and the GPU in question is a relatively new one: GeForce RTX 2060 SUPER.

Thank you in advance!


I could manage to resolve the issue, the solution was to properly reinstall NVIDIA driver, when logged in with the new kernel. The dnf remove akmod-nvidia didn’t remove all driver components, I had to run dnf remove xorg-x11-drv-nvidia\* instead. (I realized, also in the driver’s documentation this is the suggested way to remove the driver.) After the driver was fully removed, reinstalling by dnf install akmod-nvidia did the trick.

I also upgraded to Fedora 36 then, which perfectly works with the NVIDIA driver after these steps. :+1: