Fedora Encrypted Root With Automatic USB Key Unlocking?

i have tried many outdated guides still no luck, here is what i have setup right now and the current guides im looking at:

use gnome disks to identify uuid of my nvme drive and my usb

use gnome disks to format the usb to fat and named the usb drive “keys”

also identify the correct full path to my usb so i can write the keyfile to it

the first command to create keyfile on my usb drive i named the the key file “mykeyfile” then next command adds that key file to luks as a new keyslot

sudo dd bs=512 count=4 if=/dev/random of=/run/media/fractal/22C9-8F3F/mykeyfile iflag=fullblock

sudo cryptsetup luksAddKey /dev/nvme1n1p3 /run/media/fractal/keys/mykeyfile

sudo cryptsetup luksDump /dev/nvme1n1p3 to check if key slot was added and it was

sudoedit /etc/crypttab
luks-8f088ed4-6738-43a6-9b7f-fda6c800ba7b UUID=8f088ed4-6738-43a6-9b7f-fda6c800ba7b /run/media/fractal/keys:LABEL=keys luks,keyfile-timeout=30s

sudoedit /etc/default/grub
GRUB_CMDLINE_LINUX=“rd.luks.uuid=luks-8f088ed4-6738-43a6-9b7f-fda6c800ba7b rhgb quiet mem_sleep_default=s2idle ipv6.disable=1 module.sig_enforce=1 rd.luks.key=22C9-8F3F=/run/media/fractal/keys:LABEL=keys rd.luks.options=8f088ed4-6738-43a6-9b7f-fda6c800ba7b=keyfile-timeout=30s”

sudo dracut -f

sudo grub2-mkconfig -o /boot/grub2/grub.cfg

reboot, still the same password prompt

someone said if i edit crypttab then grub edits not needed vice versa, so i commented out the crypttab and still no luck

here is some other steps im trying

filesystems+=" fat "
Or use whichever filesystem you formatted your USB drive with then rebuild dracut
sudo dracut -f

found this in a silverblue guide:

add_drivers+=" fat "
add_drivers+=" vfat "



what am i doing wrong?