Fedora 39 USB-C video output, integrated camera and bluetooth issue on HP laptop

I’m using Fedora 39 Gnome (standard installation) on HP ProBook 455 15.6 inch G10 Notebook PC with AMD Ryzen™ 7 7730U with Radeon™ Graphics × 16.

For some time now I have issues with external monitor. Monitor is recognized by OS, but resolution is completely wrong and monitor receives no signal from PC.
image

This monitor is connected with my laptop through HDMI and USB-C hub.

I had this issue before but I was able to “fix” it when I plug the laptop to other monitor which has direct USB-C video input. At first, when I was doing this, Fedora would freeze a bit, cursor is hard to move arround, like system is broken. Then, after restart, everything would work fine on both monitors. One that is connected through USB-C hub and one that is connected directly through USB-C.

It’s worth to mention that issues are starting mostly after I use another USB-C hub with external monitor attached to it over HDMI. This monitor is the same as the first one but USB-C hub is different.

After latest Fedora update, I can’t get it to work at all. Neither monitor is working through USB-C hub over HDMI, nor over direct USB-C video output. USB-C direct connection makes OS freeze and unusable untill I plug the USB-C out.

Second issue is integrated camera. From time to time it just stops working. I thought that it’s because of some updates, but now I see it stopped working and then, suddenly, without any noticeable reason, started working again. Applications is recognizing cammera but there is no image from it. Camera was not working yesterday and today whole day but now I turned the Cheese app again just to make a screenshot of the sympthoms and it’s working again… How, I have no idea…

Third issue is with Bluetooth. This has never worked and it’s not so important to me so I just mentioned it. I can see bluetooth devices but when I try to connect to it, suddenly all recognized devices got deleted. Also, I can’t see my laptop’s bluetooth on other devices like my phone etc.

Can you please give some explanation on what is going on with displays and USB-C port, why is it sometimes working and sometimes not? How is it possible that sometimes it starts working after plugging in different monitor but sometimes, like now, it’s not working at all… What can I do to address this issue?

Please let me know if I should provide some logs etc…

Thank you in advance.

Update,

I’ve just tried couple of more times to plug in and out monitor with direct USB-C. I plug it once and Fedora froze, unpluged it and pluged it again and it worked!?!?

Now everything works fine! Both monitor that I connect with HDMI over USB-C hub and other monitor which goes directly to USB-C. Also integrated camera is working fine!???

image

Can anyone make any sense out of this please?

Also hardware logs for connected hub looks odd

What’s going on, looks like my laptop is alive and moody???

Sometimes the order in which things are done matters and Linux USB-C hubs too often have glitches in support for Linux (sometimes fixed with firmware updates). My USB hub has a “race” issue where it doesn’t fully initialize before linux loads when first started. Dual boot systems sometimes work differently when Windows is used before Linux.

Please make sure you have current firmware in your system and hubs, and that Fedora is fully updated so you aren’t chasing issues that have been fixed.

Use journalctl to find relevant log entries, but note that it collects a massive amount of data so some effort is needed to find a filter that selects relevant entries for a particular issue. See: How to use journalctl and man journalctl.

The Bluetooth issue is likely unrelated to the issues with hubs and monitors. I rarely use BT since the puppy ate my BT ear buds, but some sites I use replace the hardware phone line requirement with a requirement to use BT to demonstrate proximity to my smartphone. I suspect such requirements will become more common. Others have reported similar BT issues here. Some BT hardware does not have robust drivers for linux, so the easy “fix” is to use a USB BT dongle or a wifi+BT card that is well supported in linux.

1 Like

@gnwiii , thank you very much for all the information. I appreciated it.

I have update regarding bluetooth. It’s incredible…
I’ve tried today first time the latest live Ubuntu 23.10, just for the reference. Bluetooth worked out of the box. But that is not the strange part. Strange part is that now, when I switched back to installed Fedora, bluetooth is working for the first time on Fedora as well!

I don’t know if Ubuntu installed some kind of firmware or what, but for me this is realy incredible. I can’t explain it.

Also integrated camera on Fedora stopped working again, and then, out of the blue, it started working again. I really feel like my laptop is possesed or something…