Fedora 38 HEIC problem

Hi Everyone!

I upgraded my laptops and my pc to Fedora 38. I had a conflict problem with libheif* packages what I removed.

Since the system was upgraded I can not open the HEIC photos.

I have the libheif-freeworld and libheif installed at the moment.

How can I solve this problem?

Thanks for help!

It would certainly help if you would tell us exactly what packages you removed to do the upgrade.

Reinstalling the same should fix the problem but we cannot guess what you did.

Nope. I reinstalled all (from Fedora repository), but don’t work.

The libheif* from Fedora repository not works since 37, but the same packages from RPMFusion worked.
But since 38 the RPMFusin repository does not contain libheif* packages, just “libheif-freeworld”, but this not works too.

[libheif* means:

$ sudo dnf search libheif
===============================================================================
libheif.x86_64 : HEIF and AVIF file format decoder and encoder
libheif.i686 : HEIF and AVIF file format decoder and encoder
libheif-devel.x86_64 : Development files for libheif
libheif-devel.i686 : Development files for libheif
libheif-freeworld.x86_64 : HEVC support for HEIF and AVIF file format decoder and encoder
libheif-tools.x86_64 : Tools for manipulating HEIC files

]

Which of those packages are installed?
dnf list 'libheif*' will tell us which are installed and which are available.

1 Like
libheif.x86_64   1.15.1-2.fc38    @fedora                
libheif-devel.x86_64     1.15.1-2.fc38      @fedora                
libheif-freeworld.x86_64    1.15.1-5.fc38    @rpmfusion-free-updates
libheif-tools.x86_64  1.15.1-2.fc38   @fedora                

You didn’t mention how you’re trying to open the HEIC photos.
If it is through tools using gdk-pixbuf (such as GNOME’s image preview) you’d also need to install heif-pixbuf-loader for those to make use of libheif.

2 Likes

I use Fedora 38 with KDE Plasma. I have installed qt-heif-image-plugin but I cannot open the heic files whit any software.

I just remembered that there was an update recently that replaced any libheif that you may have installed from RPMFusion before with a version from Fedora that does not contain the neccessary decoders for HEIC images.
You may need to install libheif-freeworld from RPMFusion.

1 Like

Yes. I have installed. See above.
Does not work.

Looks like it may be a bug in qt-heif-image-plugin then. Tried it with lximage-qt and nomacs and both cannot read a .heic file that Eye of GNOME has no issue reading using the heif-pixbuf-loader. So at least that confirms to me that libheif and libheif-freeworld are generally working and there must be an issue with the Qt part of things.

2 Likes

Thank you!

I had this issue too earlier,

though installed those packages aforementioned and it solved my problem.

[root@fedora isaiah]# dnf list 'libheif*'
Last metadata expiration check: 1:19:36 ago on Tue 17 Oct 2023 19:37:50.
Installed Packages
libheif.x86_64                                                      1.16.2-2.fc38                                             @updates               
libheif-freeworld.x86_64                                            1.16.2-2.fc38                                             @rpmfusion-free-updates
Available Packages
libheif.i686                                                        1.16.2-2.fc38                                             updates                
libheif-devel.i686                                                  1.16.2-2.fc38                                             updates                
libheif-devel.x86_64                                                1.16.2-2.fc38                                             updates                
libheif-tools.x86_64   

But i also found I needed to install heif-pixbuf-loader

these images formats are the stock image for iphone i beleive so they are quite imporant.

I opened new topic for f39, which doesn’t work the same as f38 regarding heic. Fedora SilverBlue 39 heic problem

1 Like