Fedora 37 NVIDIA kernel module missing. Falling back to nouveau

Piece of cake!

Even when the in “my machine” (fedora 37 KDE - nvidia driver 390xx) dnf list installed *nvidia* didn’t show any kmod-nvidia, I’ve rebooted and everything went as expected. Maybe the desktop or the driver version are involved in that third step issue, so if you are in the same scenario it could help wait several minutes (to be safer) and reboot anyways, but take this suggestion as a pinch of salt.

I was assuming to revert f36, but these three statements allowed me to go on so I can’t be more grateful to Jeff ant the forum.

Keep it up!
*(no typo, no h at the end of my name, it’s a Catalan name :sunglasses:).

PS.: I felt welcome to the ask :fedora: community from the first login. And this feeling is getting better and better all the way.

Hi Jeff,

I am very beginner and I just created an account to tell you that, the 3 last commands worked just fine for me, thank you very much, much appreciated it.

1 Like

Hello Marcos and welcome to ask :fedora:

I am glad you were able to find this and that the suggested commands worked for you.
Remember that the 470xx driver only applies if your GPU is old enough that the newer 525.60 driver does not work, and that the 470xx driver does not support wayland so you will be limited to only run xorg for the desktop.

Anyway, enjoy . :cowboy_hat_face:

1 Like