Fedora 37 KDE Spin - Kernel 6.0.10 not booting

Hello guys,

I ran into an issue when I was trying to boot my laptop and get some work done: it wouldn’t boot. It just gets passed the manufacturer splash screen and then I get a black screen and nothing happens. I updated my KDE Spin of Fedora 37 a couple of days ago ( can’t remember when the newer kernel arrived ) to the 6.0.10 kernel and after than, the first 2 boots were kinda lagging but eventually got into the login screen. But today it wouldn’t boot at all. If i tried to push ESC or SHIFT to see where it stops I got a message that it does not find any boot device. I rebooted and selected the 6.0.9 kernel and all is smooth and boots just fine.
So at this point I am blaming this on the latest kernel (6.0.10). Let me know what do you want as additional data so that you can start to investigate this issue. I am using a Dell Latitude E5570 laptop, and Fedora boots from an NVMe drive.

Sorry for the lack of important details but it is my first time reporting an issue with Fedora. I have been using it since release 32 and I am very happy with it. Never had a kernel issue before.


sudo grubby --info=ALL

to start


Hello Joe,

I wish I could do that but today when I wanted to run the command that you texted I could not boot into either 6.0.8, 6.0.9 or 6.0.10 kernels. I could not boot into the Fedora 36 rescue snapshot either. When I did I got the following messages:

Reloading system manager configuration
Starting default target
[FAILED] Failed to mount boot-efi.mount - /boot/efi.
[DEPEND] Dependancy failed for local-fs.target - Local File System
[DEPEND] Dependancy failed for selinux-autorelabel-mark.service  - Mark the need to relabel after reboot.

So yeah, no way to boot. Last time I could boot from the 6.0.9 kernel snapshot I got a message from selinux saying if I am OK with the AVC configuration or something (can’t remember). Not sure if this is useful but I mentioned it nonetheless.


Do you know if you have an nvidia GPU? and are you using the nvidia driver?

If using the nvidia GPU and drivers then from the grub menu press e to edit the options, then on the line that begins with linux and edit that line. Change where it says nvidia-modeset=1 to a nvidia-modeset=0 then see if it will properly boot.

If not using an nvidia GPU follow the same steps but just add nomodeset to that same line.

It is possible that this will at least allow booting and then you can fix whatever went wrong. If the change of that line still does not boot properly then let us know the results and what you did so we can try another possibility.

Hello Jeff

I have integrated GPU (Intel), no Nvidia GPU.
I added the nomodeset at the end of the linux line and it boots!! What could be the issue then?

I also ran the sudo grubby --info=ALL command, per Joe’s request and here is the output:

args="ro rootflags=subvol=root rhgb quiet"
title="Fedora Linux (6.0.10-300.fc37.x86_64) 37 (KDE Plasma)"
args="ro rootflags=subvol=root rhgb quiet"
title="Fedora Linux (6.0.9-300.fc37.x86_64) 37 (KDE Plasma)"
args="ro rootflags=subvol=root rhgb quiet"
title="Fedora Linux (6.0.8-300.fc37.x86_64) 37 (KDE Plasma)"
args="ro rootflags=subvol=root rhgb quiet"
title="Fedora Linux (0-rescue-b8825e89356f40048deb38b34d4d3464) 36 (KDE Plasma)"

I have also got that SElinux notification that I was telling Joe about, but couldn’t remember what was all about. Here is the notification with details:

SELinux is preventing systemd-gpt-aut from using the sys_admin capability.

*****  Plugin catchall (100. confidence) suggests   **************************

If you believe that systemd-gpt-aut should have the sys_admin capability by default.
Then you should report this as a bug.
You can generate a local policy module to allow this access.
allow this access for now by executing:
# ausearch -c 'systemd-gpt-aut' --raw | audit2allow -M my-systemdgptaut
# semodule -X 300 -i my-systemdgptaut.pp

Additional Information:
Source Context                system_u:system_r:systemd_gpt_generator_t:s0
Target Context                system_u:system_r:systemd_gpt_generator_t:s0
Target Objects                Unknown [ capability ]
Source                        systemd-gpt-aut
Source Path                   systemd-gpt-aut
Port                          <Unknown>
Host                          fedora
Source RPM Packages
Target RPM Packages
SELinux Policy RPM            selinux-policy-targeted-37.15-1.fc37.noarch
Local Policy RPM              selinux-policy-targeted-37.15-1.fc37.noarch
Selinux Enabled               True
Policy Type                   targeted
Enforcing Mode                Enforcing
Host Name                     fedora
Platform                      Linux fedora 6.0.10-300.fc37.x86_64 #1 SMP
                              PREEMPT_DYNAMIC Sat Nov 26 16:55:13 UTC 2022
                              x86_64 x86_64
Alert Count                   2
First Seen                    2022-12-03 00:22:10 EET
Last Seen                     2022-12-04 23:53:09 EET
Local ID                      c48653b2-46af-44ee-a77c-c13407860a98

Raw Audit Messages
type=AVC msg=audit(1670190789.288:303): avc:  denied  { sys_admin } for  pid=3207 comm="systemd-gpt-aut" capability=21  scontext=system_u:system_r:systemd_gpt_generator_t:s0 tcontext=system_u:system_r:systemd_gpt_generator_t:s0 tclass=capability permissive=0

Hash: systemd-gpt-aut,systemd_gpt_generator_t,systemd_gpt_generator_t,capability,sys_admin

Let me know what could be issue.