Fedora 36 is running slow, and almost crashes when i am multitasking

I am using Fedora 36 and it was pretty fast at the beginning but after a few software installations, all system is very slow. It almost never lets me multitask, if two applications are opened it brings me a NOT RESPONDING - FORCELY STOP dialog box.

Windows 10 was running smoothly without any lags or freezes.

And I have a Nvidia GeForce 820M Graphics Card which is probably not utilized, as 1080p youtube video almost freezes without any CPU heat.

Can i knows what causing the error.

1 Like

Here are the outputs of inxi -Fzx and lsblk

  Kernel: 5.19.9-200.fc36.x86_64 arch: x86_64 bits: 64 compiler: gcc
    v: 2.37-36.fc36 Desktop: GNOME v: 42.5
    Distro: Fedora release 36 (Thirty Six)
  Type: Portable System: Dell product: Inspiron 3542 v: N/A
    serial: <superuser required>
  Mobo: Dell model: 0926J6 v: A14 serial: <superuser required> UEFI: Dell
    v: A14 date: 05/23/2018
  Info: dual core model: Intel Core i5-4210U bits: 64 type: MT MCP
    arch: Haswell rev: 1 cache: L1: 128 KiB L2: 512 KiB L3: 3 MiB
  Speed (MHz): avg: 1056 high: 1386 min/max: 800/2700 cores: 1: 1090 2: 948
    3: 800 4: 1386 bogomips: 13567
  Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
  Device-1: Intel Haswell-ULT Integrated Graphics vendor: Dell driver: i915
    v: kernel arch: Gen7.5 bus-ID: 00:02.0
  Device-2: NVIDIA GF117M [GeForce 610M/710M/810M/820M / GT
    vendor: Dell driver: nouveau v: kernel arch: Fermi bus-ID: 08:00.0
  Device-3: Suyin Integrated_Webcam_HD type: USB driver: uvcvideo
    bus-ID: 1-1.5:4
  Display: wayland server: X.Org v: with: Xwayland v: 22.1.3
    compositor: gnome-shell driver: gpu: i915 resolution: 1366x768~60Hz
  OpenGL: renderer: Mesa Intel HD Graphics 4400 (HSW GT2)
    v: 4.6 Mesa 22.1.7 direct render: Yes
  Device-1: Intel Haswell-ULT HD Audio vendor: Dell driver: snd_hda_intel
    v: kernel bus-ID: 00:03.0
  Device-2: Intel 8 Series HD Audio vendor: Dell driver: snd_hda_intel
    v: kernel bus-ID: 00:1b.0
  Sound Server-1: ALSA v: k5.19.9-200.fc36.x86_64 running: yes
  Sound Server-2: PulseAudio v: 15.0 running: no
  Sound Server-3: PipeWire v: 0.3.58 running: yes
  Device-1: Qualcomm Atheros QCA9565 / AR9565 Wireless Network Adapter
    vendor: Dell driver: ath9k v: kernel bus-ID: 06:00.0
  IF: wlp6s0 state: up mac: <filter>
  Device-2: Realtek RTL810xE PCI Express Fast Ethernet vendor: Dell
    driver: r8169 v: kernel port: e000 bus-ID: 07:00.0
  IF: enp7s0 state: down mac: <filter>
  Device-1: Qualcomm Atheros AR9462 Bluetooth type: USB driver: btusb v: 0.8
    bus-ID: 1-1.6:11
  Report: rfkill ID: hci0 rfk-id: 3 state: down bt-service: enabled,running
    rfk-block: hardware: no software: yes address: see --recommends
  Local Storage: total: 931.51 GiB used: 30.36 GiB (3.3%)
  ID-1: /dev/sda vendor: Toshiba model: MQ01ABD100 size: 931.51 GiB
  ID-1: / size: 220.03 GiB used: 30.05 GiB (13.7%) fs: btrfs dev: /dev/sda9
  ID-2: /boot size: 973.4 MiB used: 272.5 MiB (28.0%) fs: ext4
    dev: /dev/sda5
  ID-3: /boot/efi size: 496 MiB used: 40 MiB (8.1%) fs: vfat dev: /dev/sda1
  ID-4: /home size: 220.03 GiB used: 30.05 GiB (13.7%) fs: btrfs
    dev: /dev/sda9
  ID-1: swap-1 type: zram size: 3.73 GiB used: 1.56 GiB (41.8%)
    dev: /dev/zram0
  System Temperatures: cpu: 54.0 C mobo: 54.0 C
  Fan Speeds (RPM): cpu: 2354
  Processes: 273 Uptime: 1h 11m Memory: 3.73 GiB used: 2.73 GiB (73.1%)
  Init: systemd target: graphical (5) Compilers: gcc: 12.2.1 Packages: 6
  note: see --pkg Shell: Bash v: 5.1.16 inxi: 3.3.19
loop0    7:0    0 998.6M  1 loop /var/lib/snapd/snap/android-studio/123
loop1    7:1    0 114.9M  1 loop /var/lib/snapd/snap/core/13741
loop2    7:2    0  55.6M  1 loop /var/lib/snapd/snap/core18/2566
loop3    7:3    0 194.9M  1 loop /var/lib/snapd/snap/flutter/126
loop4    7:4    0  63.2M  1 loop /var/lib/snapd/snap/core20/1623
sda      8:0    0 931.5G  0 disk 
├─sda1   8:1    0   500M  0 part /boot/efi
├─sda2   8:2    0    40M  0 part 
├─sda4   8:4    0   750M  0 part 
├─sda5   8:5    0     1G  0 part /boot
├─sda6   8:6    0 200.4G  0 part 
├─sda7   8:7    0 508.7G  0 part 
└─sda9   8:9    0   220G  0 part /home
sr0     11:0    1 287.5M  0 rom  
zram0  252:0    0   3.7G  0 disk [SWAP]

You don’t have that much RAM to begin with.

Which ones?

Which two applications?

Use your desktop’s resource manager (e.g. “System Monitor” in GNOME) to see how much memory each of your applications consumes.

1 Like

You are using the nouveau driver for your nvidia card. Nouveau is unable to support hardware acceleration on the nvidia card and it is possible that the need to do software rendering with the cpu is slowing things down a lot.

If that is the case, the best fix would be to install the nvidia drivers which manage hardware acceleration for you.

1 Like

And in addition, since you have too little RAM, your CPU is busy compressing and decompressing memory that is swapped into zram. System monitor will show. Glad there is zram in Fedora. If you would swap onto your really slow HDD, the experience would be even worse.

  ID-1: swap-1 type: zram size: 3.73 GiB used: 1.56 GiB (41.8%)
    dev: /dev/zram0

I won’t run heavy apps … But using atom ( text editor) and even opening a web browser ( brave ) i get a response of not responding and even sometimes it closes automatically without any warning.

I tried installing drivers. But after a restart there was an message like " Somthing not working get back to nouveau"

That could be systemd-oomd, which kills apps, when your RAM and swap are near full, see https://fedoraproject.org/wiki/Changes/EnableSystemdOomd

You need to use System Monitor (or tools like btopor htop) to watch what’s going on for your CPU and RAM. The browser alone can eat 2GB RAM for breakfast.

How did you do that? Did you follow the instructions on https://rpmfusion.org/Howto/NVIDIA by any chance?

Yes I have used the same link and followed for Legacy GeForce 600/700 is it correct, or do I need to install it for other versions?

And I would like to mention that when I boot my system I get a grub of 4+versions of fedora with Windows 10, even though I have deleted windows. When I click on windows it simply says to reinstall windows… Does this have anything to do with the problem ??

Don’t know much about nividia but usually they stop supporting old GPU’s at some point and instead of the 470 driver you may need to stick to the older 390, as in Legacy GeForce 400/500 (xorg-x11-drv-nvidia-390xx akmod-nvidia-390xx).

To remove the 470 version of the driver before installing the other one: Howto/NVIDIA - RPM Fusion

Getting an error

No match for argument: xorg-x11-drv-nvidia-390xx
No match for argument: akmod-nvidia-390xx
Error: Unable to find a match: xorg-x11-drv-nvidia-390xx akmod-nvidia-390xx

The error you’re seeing suggests that you have not enabled the RPM Fusion repository. Start by doing that and then follow the guide for your graphics card.

RPM Fusion is enabled and here is the list of repolist

$ sudo dnf repolist
repo id                         repo name
Atom                            Atom Editor
anydesk                         AnyDesk Fedora - stable
fedora                          Fedora 36 - x86_64
fedora-cisco-openh264           Fedora 36 openh264 (From Cisco) - x86_64
fedora-modular                  Fedora Modular 36 - x86_64
google-chrome                   google-chrome
phracek-PyCharm                 Copr repo for PyCharm owned by phracek
rpmfusion-free                  RPM Fusion for Fedora 36 - Free
rpmfusion-free-updates          RPM Fusion for Fedora 36 - Free - Updates
rpmfusion-nonfree-nvidia-driver RPM Fusion for Fedora 36 - Nonfree - NVIDIA Driver
rpmfusion-nonfree-steam         RPM Fusion for Fedora 36 - Nonfree - Steam
updates                         Fedora 36 - x86_64 - Updates
updates-modular                 Fedora Modular 36 - x86_64 - Updates

In that case, dnf info akmod-nvidia* should list the following packages: akmod-nvidia, akmod-nvidia-340xx, akmod-nvidia-390xx, akmod-nvidia-470xx. Is that what you see?

Also, follow the steps outlined in this post and report back.

These are the three last Fedora kernels you had installed, plus a rescue kernel. Since you’ve deleted windows, the windows boot entry you are seeing and which proposes the reinstallation of windows is probably a hidden restore partition. All of that is normal and has nothing to do with your issue.

1 Like
Available Packages
Name         : akmod-nvidia
Epoch        : 3
Version      : 515.65.01
Release      : 1.fc36
Architecture : x86_64
Size         : 27 k
Source       : nvidia-kmod-515.65.01-1.fc36.src.rpm
Repository   : rpmfusion-nonfree-nvidia-driver
Summary      : Akmod package for nvidia kernel module(s)
URL          : https://www.nvidia.com/
License      : Redistributable, no modification permitted
Description  : This package provides the akmod package for the nvidia kernel
             : modules.

Name         : akmod-nvidia-470xx
Epoch        : 3
Version      : 470.141.03
Release      : 1.fc36
Architecture : x86_64
Size         : 26 k
Source       : nvidia-470xx-kmod-470.141.03-1.fc36.src.rpm
Repository   : rpmfusion-nonfree-nvidia-driver
Summary      : Akmod package for nvidia-470xx kernel module(s)
URL          : https://www.nvidia.com/
License      : Redistributable, no modification permitted
Description  : This package provides the akmod package for the nvidia-470xx
             : kernel modules.

Did you try that?

Yes I same as before

Nvidea Kernal Models Missing, switching back to Nouveau

And after using the system monitor these are the results

After opening just VS code

It crashes and closes automatically, and after waiting for 30min with no apps running
It’s still the same

What is the output of rpm -qa akmod*?

In the “Processes” tab of System Monitor you can see how much memory each process consumes. Which are the biggest offenders? I suspect that your use of snaps makes things worse…


Even I tried to build kernels

sudo akmods --force && sudo dracut --force

which gave me a result OK