Fedora 36 Huawei Laptop Issue with Trackpad and kernel module

Okay so previously was trying to work out why the trackpad stops responding randomly on my Huawei Matebook 16. Having tried troubleshooting all manner of things i just put it down as a minor annoyance that i could just reboot when it happened.

Anyways, i have now narrowed it down to one specfic thing. I was away at the weekend and laptop was left in a hotel, i used it all weekend with not a single issue. The only difference was when i was using it it was not charging.

That led me to think that maybe the Gnome extension Huawei WMI Controls could be at fault. But then thinking about it this is just a front end for the Kernel module:

Huawei_WMI as located here - Kernel Module WMI

That has been implemented into the main line since kernel 5.5 but not updated as far as i can tell.

Outputs as follows:

filename:       /lib/modules/6.0.5-200.fc36.x86_64/kernel/drivers/platform/x86/huawei-wmi.ko.xz
license:        GPL v2
description:    Huawei WMI laptop extras driver
author:         Ayman Bagabas <ayman.bagabas@gmail.com>
alias:          wmi:ABBC0F5B-8EA1-11D1-A000-C90629100000
alias:          wmi:ABBC0F5C-8EA1-11D1-A000-C90629100000
alias:          wmi:59142400-C6A3-40fa-BADB-8A2652834100
depends:        wmi,sparse-keymap,ledtrig-audio
retpoline:      Y
intree:         Y
name:           huawei_wmi
vermagic:       6.0.5-200.fc36.x86_64 SMP preempt mod_unload 
sig_id:         PKCS#7
signer:         Fedora kernel signing key
sig_key:        7F:56:20:0F:9A:D1:48:D5:F6:FD:32:24:A8:28:64:D8:F6:EC:16:2A
sig_hashalgo:   sha256
signature:      86:1F:8A:CA:DE:77:32:B1:AB:F1:9C:7E:15:3F:C7:6D:A4:C8:B0:05:
parm:           battery_reset:Reset battery charge values to (0-0) before disabling it using (0-100) (bint)
parm:           report_brightness:Report brightness keys. (bint)


huawei_wmi             20480  0
ledtrig_audio          16384  3 snd_ctl_led,snd_hda_codec_generic,huawei_wmi
sparse_keymap          16384  1 huawei_wmi
wmi                    45056  2 huawei_wmi,wmi_bmof

How i tested this when returning home

  • Used laptop all day unplugged - Trackpad Worked 100% of the time no issues
  • Put charger back in and used laptop, WMI Controls set to stop charging automatically at 90%, as soon ass the laptop hit 90% the trackpad immediately stopped working until reboot

I guess this is something unlikely to be fixed so will probably just disable the battery protection feature for now, or just use laptop unplugged and charge when not in use, but least i found the cause as that was bugging me not knowing

As a further update, disabled the WMI setting to charge to 90% and stop, and well as soon as the charging state changes is deffo when the mousepad freezes, as this time when it switched to 100% charge it immediately froze so will pop an issue on bugzilla

Hi, I also have the Matebook 16 (R7 5800H) but with Fedora 37.

I had some freezes like you and were very annoying because after the first power-off cycle if I started Windows instead of Fedora touchpad were missing at all, no touchpad device in device manager, so there is a problem with drivers. I noticed also that touchpad is working in bios menu in this laptop, I think that there is a deep integration of the device in the system.

Now, in my current session started a day ago, I’m not using touchpad but a bluettoth mouse and sometimes I check if touchpad is working and all is ok, it also survived to a 8 hours suspension.

My issues with freezing were with Fedora 36 and OpenSuse Tumbleweed (this last one with the last kernel avaible 6 +), I don’t now if there will be also with 37, I’ll check it in the next days and report.

I forgot to write about my current battery settings, 40%-70% range thresholds.

BIOS firmware 2.28 solved trackpad issue, install it with Huawei PC Manager on Windows.

Hello everyone !

I also have the same issue with this Huawei Matebook 16, R7 with Archlinux (and Ubuntu Live as well).

I tried to update my BIOS firmware, but the problem is that the PC manager only update to 2.26, and not 2.28.

After further researches, I cannot find any BIOS 2.28 from Huawei… Where did you find it then :sweat_smile: ?

I’m actually wondering about they removed it. Is it possible ?
Thank for those who will answer.