Fedora 34 - Logitech K360 Media Keys not working


I am running a freshly installed Fedora 34 workstation with Gnome 40.4.0.

My keyboard is a wireless Logitech K360, which has multiple media keys: Volume up/down, mute, next/previous song, etc.

The media keys behave very strangely - when I press one of them (e.g. volume down) , I looks like they execute a “back action” - like when you press back in a web browser.

In Gnome settings for configuring keyboard shortcuts for audio control, the behaviour is strange too: whenever I want to configure a shortcut, my media keys don’t get recognized when I press them.

I appreciate any help.

I have the K350 keyboard, and in the settings -> keyboard -> customize shortcuts -> sound and media panel (F34) I am able to set the keys for volume up/down/mute, previous/next track, play/pause, and stop. Can’t set anything else that I found for audio.

On mine (both fedora 33 & 34) all those keys were disabled by default.

Thanks for your reply.

Do you know any way to trouble shoot / debug / analyze this issue?

Don’t know if it is related, or if you already know, but gnome extensions that used to be managed thru gnome-tweaks has been moved in gnome40 and is now found in the gnome-extensions package.

I have already installed that so I cannot compare with & without that package installed.

Without digging a lot deeper into how our installed packages for gnome compare that is the only recent change I am aware of.

Thanks for your reply.

I found the root cause, in the meantime :slight_smile:

I forgot to mention one important thing, sorry:

My K360 is not connected directly to my computer but via a KVM switch (as I switch between multiple computers).

The KVM switch is the problem - when I connect my keyboard directly to the computer, all media keys work out-of-the-box without any problems.

So, I need to reach out to the KVM switch support and ask them for trouble-shooting help.

Yep, anything between the keyboard and PC have a chance of interfering. I have not used a KVM for years because of that. Easier to move the transmitter than to have interference since I only work at home.