Fedora 30 not seen when updating grub from a debian distro

Since installing Fedora 30 alongside Deepin and Sparky linux distros Fedora is not recognised when updating grub from any of the Debian based distros. Is this a bug???

Just a guess - could be because Fedora 30 now uses something called “BLS”:


There is a way to turn it off, it’s explained in the linked page.

But personally I use a boot manager called rEFInd for multi-booting and couldn’t be happier. It’s not dependent on grub loader, grub config, or its format, it looks for (and finds) Linux kernels directly, and can boot Windows too, if you also use that.


Thank you for replying Kostya

However having now installed the latest version of Susie I can no longer boot Fedora 30 as it is not recognised by grub2 or grub using Deepin ( I like to try several distros). Am I in a catch 22 situation or is there a way to get around this. I am using a laptpop with only legacy boot.




Oh legacy boot - then rEFInd is not an option.

I’d try to turn off BLS inside Fedora and regenerate grub config in old format.

Basically it means setting GRUB_ENABLE_BLSCFG=false in /etc/default/grub and then doing grub2-mkconfig -o /boot/grub/grub.cfg

Can you use BIOS boot menu to get into Fedora? That would be easiest.

If not you should be able to mount the Fedora partition while booted into your other distro, but it’ll be necessary to use chroot so that grub2-mkconfig can find whatever it needs as if you were booted into Fedora. The “whatever it needs” is probably “dev” from your currently booted Linux, maybe “proc” and possibly others.

Sorry I can’t provide clear step by step instructions, these are just ideas hopefully pointing in the right direction. Inspired by this, by the way, to give credit where it’s due:

Here is another thought on how to get into Fedora - so you can turn off BLS there more easily, without having to mess with chroot and stuff.

If Fedora is installed on a separate physical drive (from your other distro’s) - then the BIOS boot menu should let you choose that.

If by “alongside” you meant same physical drive and let’s say Deepin on /dev/sda1 and Fedora on say /dev/sda3 - then it won’t, it will just let you pick the physical drive but not the exact partition.

Here is what you could try then.

Use a disk partition tool while booted into your other Linux to change the drive’s “active” partition to Fedora’s (right now it’s set to another distro’s which provides the initial boot into grub).

Then the system should boot from that (Fedora) partition.

Finally, after turning off BLS and regenerating Fedora’s grub config, use a disk partition tool again to change the active partition back to Deepin or whatever.

Hopefully after this your “other” distro will see Fedora’s (now non-BLS) boot information.