Fedora 30 / branching / remotes?

I see by the Fedora schedule https://fedoraproject.org/wiki/Releases/30/Schedule#Key_Milestones that the branch that separates F30 from Rawhide is scheduled for today. How long after that branch does the equivalent happen for Silverblue - when should we expect a remote for a testing version of F30 Silverblue?

Theoretically today or tomorrow. I’d say wait til next week, though, in case there are complications with branching.

1 Like

The next week is here. Any updates on this? I’m eager to switch to Fedora 30 :grinning:

I tried the rebase today rpm-ostree rebase fedora-workstation:fedora/30/x86_64/silverblue and got:

error: No such branch 'fedora/30/x86_64/silverblue' in repository summary

So I think this is not ready yet, but I would be glad to hear about any update.

There is a PR to branch to F30 for Silverblue:

https://pagure.io/workstation-ostree-config/pull-request/124

1 Like

It seems the url has changed from https://kojipkgs.fedoraproject.org/ostree/repo/ to https://kojipkgs.fedoraproject.org/compose/ostree/repo/

is this now the official url? seems that there is no summary file, so ostree remote refs does not work with that location.

just want to be sure i’m using the right one.

thanks for your help

just discovered https://github.com/ostreedev/ostree/issues/1541 so the official url should be https://ostree.fedoraproject.org.

but silverblue 30 is not available under this URL…

So this PR that I referenced was just to the config files used to generate the compose itself, not the actual branching. My apologies for any confusion.

I spoke to @dustymabe on IRC and he explained the reason the branch has not been made yet is because there has not been a successful F30 ostree compose yet.

thanks for the clarification! we just have to be patient then :slight_smile:

a little bit of topic: it’s still unclear for me where to get the new rawhide gpg key. maybe some patience is needed here as well, as everything seems to be in flux currently…

thanks
toni

I think the new Rawhide key should be included in this update:

https://bodhi.fedoraproject.org/updates/FEDORA-2019-d1da19298e

If that doesn’t work, you could try the latest F30 build

https://koji.fedoraproject.org/koji/buildinfo?buildID=1213936

thanks @miabbott!

just for reference: i downloaded the SRPM, copied the key to /etc/pki/rpm-gpg and changed to location in /etc/ostree/remotes.d/fedora-workstation.conf accordingly. rawhide updates are now working again.

I noticed that the branch is still not available. Shouldn’t this be a blocker for Fedora 30 Beta?

I’m not sure but I think that silverblue is not a blocking spin/flavour yet

Yes, but if you can’t rebase Silverblue to Fedora 30, than you don’t have Fedora 30 on Silverblue, so it’s a blocker for Fedora Silverblue itself.

3 Likes

I’ve had to abandon my Silverblue testing for a couple of weeks - a convergence of stability-requiring activities on three projects pushed me back to Arch. I should be back to Silverblue on at least one machine next week; the NVidia tooling is ready for testing.

Out of curiosity, is there a rough timeline of how long it’d take for a successful compose?

As I understand it, the ostree compose for F30 is not failing, but rather some other part of the F30 “compose all the things” process. This is gating the release of all the F30 artifacts/composes/bits.

I’m going to tag @dustymabe who can likely answer this more concretely.

1 Like

It looks like it has been failing pretty consistently. If you want to follow along the investigation when builds fail you can subscribe to https://pagure.io/dusty/failed-composes but there are quite a few issues that get opened so you’ll want to filter it.

2 Likes