F37 Freezes after roughly 10 minutes of use


Fedora 37 is freezing within roughly ten minutes of being powered on. By freezing, I mean the mouse pointer stops moving entirely, and audio cuts out after a few seconds.

ctrl+alt f3-5 sometimes works to switch to a tty, but often does not. Once in tty, I can enter my username and password when prompted, and the “last log in at:XXXXX” appears, but the username@hostname prompt never appears, it just hangs on a blinking cursor.

sshing into the machine when it is in this state either hangs when connecting, or does the same as above.

I have tried disabling all GNOME extensions and booting to an older kernel, yet the freezes persist.

Checking journalctl -r, I see that just before the freeze, pipewire-pulse prints

spa.loop: 0x55b4c12be118: queue full 88, need 152

hundreds of times. I’ve included the output of journalctl from today, you can see one such freeze at Jan 11 16:39:48

Any help debugging from here would be appreciated!

Can you provide more information about your hardware, please?

i7 4790k, GTX 1060, Focusrite 2i2.

Pipewire and pipewire-pulseaudio are from the normal @System repo. What would be the best way to get more info about the error? I found only one other person with the same issue and they abandoned their thread.

Please post (as preformatted text using the </> button) the output of inxi -Fzxx so we may see more detailed info.

  12Kernel 6.0.18-300.fc37.x86_64 12arch x86_64 12bits 64 12compiler gcc 12v 2.38-25.fc37 12Desktop GNOME
    12v 43.2 12tk GTK 12v 3.24.36 12wm gnome-shell 12dm GDM 12Distro Fedora release 37 (Thirty Seven)
  12Type Desktop 12Mobo MSI 12model Z97M-G43(MS-7924) 12v 1.0 12serial <superuser required>
    12UEFI American Megatrends 12v 1.9 12date 05/22/2015
  12Info quad core 12model Intel Core i7-4790K 12bits 64 12type MT MCP 12arch Haswell 12rev 3 12cache 12L1 256 KiB
    12L2 1024 KiB 12L3 8 MiB
  12Speed (MHz) 12avg 3343 12high 4400 12min/max 800/4400 12cores 121 2077 122 4400 123 800 124 4400 125 4400 126 1868
    127 4400 128 4400 12bogomips 63996
  12Flags avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
  12Device-1 NVIDIA GP106 [GeForce GTX 1060 6GB] 12vendor eVga.com. 12driver nvidia 12v 525.78.01
    12arch Pascal 12pcie 12speed 8 GT/s 12lanes 16 12ports 12active none 12off DP-2 12empty DP-1, DP-3, DVI-D-1,
    HDMI-A-1 12bus-ID 01:00.0 12chip-ID 10de:1c03
  12Device-2 Logitech HD Pro Webcam C920 12type USB 12driver snd-usb-audio,uvcvideo 12bus-ID 3-6:4
    12chip-ID 046d:082d
  12Display wayland 12server X.org 12v 1.20.14 12with Xwayland 12v 22.1.7 12compositor gnome-shell 12driver 12X
    12loaded nvidia 12unloaded fbdev,modesetting,nouveau,vesa 12alternate nv 12gpu nvidia,nvidia-nvswitch
    12display-ID 0
  12Monitor-1 DP-2 12model Dell U3415W 12res 3440x1440 12dpi 109 12diag 865mm (34.1")
  12API OpenGL 12v 4.6.0 NVIDIA 525.78.01 12renderer NVIDIA GeForce GTX 1060 6GB/PCIe/SSE2
    12direct render Yes
  12Device-1 NVIDIA GP106 High Definition Audio 12vendor eVga.com. 12driver snd_hda_intel 12v kernel
    12bus-ID 3-4:8 12pcie 12chip-ID 1235:8016 12speed 8 GT/s 12lanes 16 12bus-ID 01:00.1 12chip-ID 10de:10f1
  12Device-2 Focusrite-Novation Focusrite Scarlett 2i2 12type USB 12driver snd-usb-audio
  12Device-3 Logitech HD Pro Webcam C920 12type USB 12driver snd-usb-audio,uvcvideo 12bus-ID 3-6:4
    12chip-ID 046d:082d
  12Sound API ALSA 12v k6.0.18-300.fc37.x86_64 12running yes
  12Sound Server-1 JACK 12v 1.9.19 12running no
  12Sound Server-2 PulseAudio 12v 16.1 12running no
  12Sound Server-3 PipeWire 12v 0.3.63 12running yes
  12Device-1 Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet 12driver r8169 12v kernel 12pcie
    12speed 2.5 GT/s 12lanes 1 12port d000 12bus-ID 03:00.0 12chip-ID 10ec:8168
  12IF enp3s0 12state up 12speed 1000 Mbps 12duplex full 12mac <filter>
  12Local Storage 12total 8.93 TiB 12used 7.31 TiB (81.9%)
  12ID-1 /dev/nvme0n1 12vendor SK Hynix 12model HFS256GD9TNG-62A0A 12size 238.47 GiB 12speed 31.6 Gb/s
    12lanes 4 12serial <filter> 12temp 42.9 C
  12ID-2 /dev/sda 12vendor Samsung 12model SSD 850 EVO 1TB 12size 931.51 GiB 12speed 6.0 Gb/s
    12serial <filter>
  12ID-3 /dev/sdb 12vendor Samsung 12model SSD 870 QVO 2TB 12size 1.82 TiB 12speed 6.0 Gb/s 12serial <filter>
  12ID-4 /dev/sdc 12vendor Western Digital 12model WD6003FZBX-00K5WB0 12size 5.46 TiB 12speed 6.0 Gb/s
    12serial <filter>
  12ID-5 /dev/sdd 12vendor Samsung 12model SSD 850 EVO 500GB 12size 465.76 GiB 12speed 6.0 Gb/s
    12serial <filter>
  12ID-6 /dev/sde 12type USB 12vendor Kingston 12model DataTraveler 3.0 12size 57.73 GiB 12serial <filter>
  12ID-1 / 12size 464.17 GiB 12used 368.2 GiB (79.3%) 12fs btrfs 12dev /dev/sdd3
  12ID-2 /boot 12size 973.4 MiB 12used 258.3 MiB (26.5%) 12fs ext4 12dev /dev/sdd2
  12ID-3 /boot/efi 12size 598.8 MiB 12used 17.4 MiB (2.9%) 12fs vfat 12dev /dev/sdd1
  12ID-4 /home 12size 464.17 GiB 12used 368.2 GiB (79.3%) 12fs btrfs 12dev /dev/sdd3
  12ID-1 swap-1 12type zram 12size 8 GiB 12used 0 KiB (0.0%) 12priority 100 12dev /dev/zram0
  12System Temperatures 12cpu 46.0 C 12mobo 38.0 C
  12Fan Speeds (RPM) 12fan-1 0 12fan-2 0 12fan-3 771 12fan-4 789 12fan-5 0
  12Processes 462 12Uptime 1m 12Memory 31.3 GiB 12used 4.56 GiB (14.6%) 12Init systemd 12v 251
  12target graphical (5) 12default graphical 12Compilers 12gcc 12.2.1 12clang 15.0.6 12Packages 12pm rpm 12pkgs N/A

I found the issue, it appears to happen when I run out of memory due (presumably) a memory leak in nextcloud-client.

I diagnosed it by managing to ctrl+f5 into tty5 as soon as I noticed the cursor start skipping, then quickly logging in and running journalctl, where there were some messages about applications being killed due to memory pressure. Next I was able to run htop and see the offending program eating all my RAM.


You are correct. Here’s the issue upstream: