F37 and Wayland with Nvidia feels laggish on Desktop


i am not sure how to describe this best, but the mouse movement doesn’t feel precise on my second (external) monitor. Basically every movement is quite delayed/laggy. That is definately not an performance issue.
It also doesn’t feel smooth on scrolling, selecting text and stuff. Like a slight delay, but not really the typical lag…
I’ve tried smaller games which run with >200fps and they don’t feel too bad, but i am not sure if they also have these problems there…

I bought a new notebook with an Intel CPU and an Nvidia 3070 - it’s running Fedora 37 (also tried with 36). The same desktop counterparts did run fine on my previous desktop machine (although i didn’t have the internal notebook display).

Tried Wayland and X11 - the latter doesn’t recognize the notebook display so i didn’t explore that any further as i really liked (X?)Wayland on my previous machine…

What can i check here to narrow down the problem?

I already reinstalled the nvidia drivers according to the manual at rpmfusion (Howto/NVIDIA - RPM Fusion) and they are also set up like this.

Here maybe some helpful information:

The Graphic part in the Info-Dialog:

NVIDIA GeForce RTX™ 3070 Laptop GPU / Mesa Intel® Graphics (ADL GT2)
lspci -k | grep -A 2 -E "(VGA|3D)"
0000:00:02.0 VGA compatible controller: Intel Corporation Alder Lake-P GT1 [UHD Graphics] (rev 0c)
	DeviceName: Onboard - Video
	Subsystem: ASUSTeK Computer Inc. Device 136d
0000:01:00.0 VGA compatible controller: NVIDIA Corporation GA104M [GeForce RTX 3070 Mobile / Max-Q] (rev a1)
	Subsystem: ASUSTeK Computer Inc. Device 136d
	Kernel driver in use: nvidia


inxi -G
  Device-1: Intel Alder Lake-P GT1 [UHD Graphics] driver: i915 v: kernel
  Device-2: NVIDIA GA104M [GeForce RTX 3070 Mobile / Max-Q] driver: nvidia
    v: 520.56.06
  Device-3: Sonix USB2.0 HD UVC WebCam type: USB driver: uvcvideo
  Display: wayland server: X.Org v: 22.1.5 with: Xwayland v: 22.1.5
    compositor: gnome-shell v: 43.1 driver: X: loaded: nvidia dri: iris
    gpu: i915,nvidia,nvidia-nvswitch resolution: 1: 2560x1440~60Hz
    2: 1920x1080~144Hz
  OpenGL: renderer: Mesa Intel Graphics (ADL GT2) v: 4.6 Mesa 22.2.3


Mon Nov 21 20:19:52 2022       
| NVIDIA-SMI 520.56.06    Driver Version: 520.56.06    CUDA Version: 11.8     |
| GPU  Name        Persistence-M| Bus-Id        Disp.A | Volatile Uncorr. ECC |
| Fan  Temp  Perf  Pwr:Usage/Cap|         Memory-Usage | GPU-Util  Compute M. |
|                               |                      |               MIG M. |
|   0  NVIDIA GeForce ...  Off  | 00000000:01:00.0  On |                  N/A |
| N/A   46C    P8    10W /  N/A |     38MiB /  8192MiB |      0%      Default |
|                               |                      |                  N/A |
| Processes:                                                                  |
|  GPU   GI   CI        PID   Type   Process name                  GPU Memory |
|        ID   ID                                                   Usage      |
|    0   N/A  N/A      2217      G   /usr/bin/gnome-shell                2MiB |

This looks fine to me, but maybe someone else has an idea what might be wrong.

1 Like

Please explain the “doesn’t recognize” part.
There is a somewhat obscure feature in most laptops that users may not understand. The iGPU is intended to use the built-in screen and the dGPU is mostly intended to control an external monitor.

With X this is easily overcome by following the steps shown in the link below to copy the nvidia.conf file but NOT editing the nvidia.conf file unless you truly want the nvidia GPU to be used as primary full time. The lines in that file allow the nvidia GPU to control both screens or just the laptop screen at users choice. The edit makes the nvidia the primary and only active GPU.

If you are using wayland this is not effective.

When i log in to my account with X enabled the internal display (notebook display) stays black and is not shown in the Fedora Display Setting-Menu. The external Display (connected to the HDMI outlet, which i assume is from my Graphic Card) works okay, but i also need/want the notebook display.

Thanks for your description and link. Will check that out in the evening. Your tip also helped me search for another solution which may also apply (sort of) to Wayland - there seem to be a Gnome-Extension which lets you switch on what GPU you want to use as main GPU. Going to try that too and report back in the evening.
Thanks for the suggestions!

So that project i mentioned was deprecated/outdated but i found another thing which does the same thing i think:

With that i managed to switch to the Dedicated GPU MUX Setting and after a restart everything is super smooth :slight_smile:

Thanks for your help