External monitors + DisplayPort + NVidia RTX issues

Allow me to set the scene with some initial data points.

inxi -SMG shows:

  Host: JBLADE.lan Kernel: 5.15.5-200.fc35.x86_64 x86_64 bits: 64 
  Desktop: GNOME 41.1 Distro: Fedora release 35 (Thirty Five) 
  Type: Laptop System: Razer 
  product: Blade 15 Base Model (Early 2020) - RZ09-0328 v: 5.04 
  serial: <superuser required> 
  Mobo: Razer model: DA550 v: 4 serial: <superuser required> UEFI: Razer 
  v: 01.06 date: 09/16/2020 
  Device-1: Intel CometLake-H GT2 [UHD Graphics] driver: i915 v: kernel 
  Device-2: NVIDIA TU106M [GeForce RTX 2060 Mobile] driver: nvidia v: 470.86 
  Device-3: IMC Networks USB Camera type: USB driver: uvcvideo 
  Display: x11 server: X.Org 1.20.11 driver: loaded: modesetting,nvidia 
  unloaded: fbdev,nouveau,vesa resolution: 1: 1920x1080~144Hz 
  2: 1920x1080~144Hz 3: 3440x1440~85Hz 
  OpenGL: renderer: Mesa Intel UHD Graphics (CML GT2) v: 4.6 Mesa 21.2.5 

xrandr --listmonitors shows:

Monitors: 3
 0: +*eDP-1 1920/344x1080/193+587+1440  eDP-1
 1: +DP-1-0 1920/531x1080/298+3440+114  DP-1-0
 2: +HDMI-1-0 3440/800x1440/335+0+0  HDMI-1-0

I have two external monitors:

  • 34GN850-B LG 34" screen plugged into the HDMI port of the Razer.
  • 27FL650F LG 27" screen plugged in to a Dell D6000 dock HDMI port, which is plugged into my Razer via thunderbolt.

Note I have the RTX 2060 and the nvidia drivers installed and nvidia-settings brings up the nvidia gui, which clearly shows the external two monitors.

Now, the problem - my 27" screen does not show anything - it goes into stand-by mode.

The monitor settings show no real reason for this and when I switch the monitors between ports, the problem swaps monitors, meaning it’s the connection, not the monitor that is the issue.

The other problem I have is that this D6000 dock has two DisplayPort options which have never worked on Fedora. I boot windows and it recognises:
2 x external monitors > 2x DisplayPorts > 1x thunderbolt > Razer
I boot into Fedora and not a peep, they only seem to work via HDMI.

Any assistance would be greatly appreciated!

Two things I would suggest off the top of my head.

  1. If not already done, copy the file /usr/share/X11/xorg.conf.d/nvidia.conf
    to /etc/X11/xorg.conf.d/nvidia.conf
  2. Edit the file /etc/X11/xorg.conf.d/nvidia.conf and place the line Option "Primary" "yes" in both stanzas of that file, then reboot and see if there is any difference.

What that file will do is make it possible for the nvidia card to manage all the outputs and it will supercede the IGP (intel) which seems to always want to take control of the laptop screen and can interfere with the dGPU (nvidia) managing the other outputs.

Thanks for your help. When I got the nvidia driver going, it actually wouldn’t recognise my laptop screen until I ran:

cd /etc/X11
sudo rm xorg.conf

I’ll give your idea a shot and report back.

Strangely, that file does not exist - see below:

[joel@fedora ~]$ cd /etc/X11/xorg.conf.d/
[joel@fedora xorg.conf.d]$ ls
[joel@fedora xorg.conf.d]$ cd /usr/share/X11/xorg.conf.d/
[joel@fedora xorg.conf.d]$ ls -l
total 32
-rw-r--r--. 1 root root   92 Jul 30 23:44 10-amdgpu.conf
-rw-r--r--. 1 root root 1099 May 29  2018 10-evdev.conf
-rw-r--r--. 1 root root 1350 Jul 24 11:56 10-quirks.conf
-rw-r--r--. 1 root root   92 Oct 16  2019 10-radeon.conf
-rw-r--r--. 1 root root 1429 Sep 20 02:58 40-libinput.conf
-rw-r--r--. 1 root root 3458 Oct  1  2019 70-wacom.conf
-rw-r--r--. 1 root root  198 Sep 21 10:19 71-libinput-overrides-wacom.conf
-r--r--r--. 1 root root  489 Dec  1 12:32 nvidia-drm-outputclass.conf

Should I just create it?

Even odder - locate says it’s there, but I cannot see it.

[joel@fedora ~]$ locate nvidia.conf

[joel@fedora ~]$ cd /etc/X11/xorg.conf.d/

[joel@fedora xorg.conf.d]$ ls -la
total 4
drwxr-xr-x. 1 root root  32 Dec  1 13:50 .
drwxr-xr-x. 1 root root 184 Dec  1 13:53 ..
-rw-r--r--. 1 root root 311 Dec  1 05:27 00-keyboard.conf

The file I noted is installed when installing the drivers from rpmfusion with the xorg-x11-drv-nvidia package. If you did not install the drivers from rpmfusion then is it likely you do not have it.

Which driver is installed and where from?

You can just create it. If you want to do so then just put this content in the file.

#This file is provided by xorg-x11-drv-nvidia
#Do not edit

Section "OutputClass"
	Identifier "nvidia"
	MatchDriver "nvidia-drm"
	Driver "nvidia"
	Option "AllowEmptyInitialConfiguration"
	Option "SLI" "Auto"
	Option "BaseMosaic" "on"
	Option "Primary" "yes"

Section "ServerLayout"
	Identifier "layout"
	Option "AllowNVIDIAGPUScreens"
	Option "Primary" "yes"
1 Like

I tried installing via “Software” and was getting problems, so went to the nvidia site and downloaded the driver direct from there.


[joel@JBLADE ~]$ nvidia-smi
Wed Dec  1 16:02:19 2021       
| NVIDIA-SMI 470.86       Driver Version: 470.86       CUDA Version: 11.4  

That explains the missing file. I edited my earlier post with the content for the /etc/X11/xorg.conf.d/nvidia.conf file and it already contains the extra lines I recommended.

Just adding those details in now and will reboot and report back. Thanks!

Just fyi:
I almost never use the gnome software app to do installs or updates. I have occasionally had issues doing so.

My standard practice is to use dnf for updates and installs, as well as full distro upgrades when a new version comes out. It just works for me so I stick with what has proven reliable.

I also only have the standard fedora repos and rpmfusion repos enabled for routine use.

I have returned, but no 27" visuals unfortunately.

I also rarely use the software app either but thought I’d give the nvidia drivers a shot because they were there. I prefer the terminal methods when there’s the option.

OK, so the monitor using the docking station output is still not working. The only other thing I can suggest is that you remove the drivers from nvidia and install the packages from rpmfusion since they have already been tweaked for fedora. I cannot tell if it will help with the docking station issue, but as I stated I have had very good luck with the drivers from rpmfusion on all my systems, including my laptop.

You also will want to remove the cuda packages you currently have since rpmfusion includes the cuda packages as part of the nvidia driver packages.

These links will help if you go down that path.