Enterprise wireless authentication

Hello everybody,
This is going to be my first question on this forum, and I hope I am going to find a solution:) I’ve recently installed Fedora 37 on my Dell Latitude 7420.
I can connect to my home wi-fi, and it is working fine, but my issue is when I try to connect college’s Wi-fi, it keeps prompting me with this message:

I did connect to this network on different distributions with exact same configurations and credentials, and there was no issue. Any idea regarding solving this issue will be appreciated.

It doesn’t happen to be an eduroam network, by chance? And in general, perhaps double-checking the network’s expected security configuration - PEAP, WPA2, all of that - vs. how your system is trying to connect might help?


Thanks for your reply John. Looks like the college use a legacy version of SSL. I run “sudo update-crypto-policies --set LEGACY”, and it looks like my connection is working for now!

It did worked for me. Thx
Screenshot from 2024-01-10 13-19-07

1 Like