Docker-compose package python dependencies missing in Fedora 38?

Running the command:

sudo dnf install docker-compose

gives the following error on fedora 38:

Last metadata expiration check: 0:10:12 ago on Fri 21 Apr 2023 15:38:55 EEST.

Problem: conflicting requests

  • nothing provides python3-dockerpty >= 0.4.1 needed by docker-compose-1.29.2-7.fc38.noarch
  • nothing provides python3.11dist(dockerpty) >= 0.4.1 needed by docker-compose-1.29.2-7.fc38.noarch
    (try to add ‘–skip-broken’ to skip uninstallable packages)

I’m a bit confused since yesterday i upgraded my x86 Intel based server from 37 to 38 and docker-compose worked just fine. Now on my work laptop where i went from 36 to 38 these python packages cannot be found by dnf. What is going on and how can i fix it?

Can i just install the python dependencies using pip and tell the docker-compose package to use them from there instead? If so how is a safe way to do it?

Thanks in advance.

Found workaround: Simply install the fedora 37 package. Download it from here:

and install using:
sudo dnf install ./python3-dockerpty-0.4.1-26.fc37.noarch.rpm

seems to work fine.

Should probably be fixed some proper way as well no?

There is python3-dockerpty-0.4.1-26.fc37.noarch. You could verify that it is installed in the system upgraded from f37. In general, life with multiple systems is easier if the configurations match, so if python3-dockerpty-0.4.1-26.fc37.noarchis installed on your server, you should install it on the laptop: doas dnf --releasever=37 python3-dockerpty.

I’ve got the same problem trying installing docker-compose on Fedora 38, I solved with your workaround. Thanks.

@jweckman a better aproach is:


docker compose is offered now as a plug-in for DOCKER :

  1. you can see here in docker-cli linux repo: → Index of linux/fedora/37/x86_64/stable/Packages/

  2. just install with sudo sudo dnf install docker-compose-plugin

  3. execute as docker compose [commands]: → docker compose | Docker Documentation


fedora docker repo for 38 release is not ready yet → no stable docker-ce releases available in the Fedora 38 repo · Issue #1456 · docker/for-linux · GitHub

Another workaround

instead of installed a version from :fedora: 37 here is the workaround for this bug:

sudo dnf upgrade --enablerepo=updates-testing --refresh --advisory=FEDORA-2023-dcf5ef9eda

from here:

Related Bugs


1 Like