Dnf upgrade, nothing provides libopenvdb.so.8.0()(64bit)

It looks like that libopenvdb.so.8.0()(64bit) Is not a part of my installation. Could it be that is just for Fedora 33 ?

Dependencies resolved.

 Problem: cannot install the best update candidate for package OpenImageIO-
  - nothing provides libopenvdb.so.8.0()(64bit) needed by OpenImageIO-
 Package                    Architecture          Version                          Repository              Size
Skipping packages with broken dependencies:
 OpenImageIO                x86_64                        updates                2.3 M


dnf info openimageio
Last metadata expiration check: 2:35:27 ago on Wed 17 Feb 2021 09:30:11 PM -03.
Installed Packages
Name         : OpenImageIO
Version      :
Release      : 1.fc32
Architecture : x86_64
Size         : 11 M
Source       : OpenImageIO-
Repository   : @System
From repo    : updates
Summary      : Library for reading and writing images
URL          : https://sites.google.com/site/openimageio/home
License      : BSD and MIT
Description  : OpenImageIO is a library for reading and writing images, and a bunch of related
             : classes, utilities, and applications. Main features include:
             : - Extremely simple but powerful ImageInput and ImageOutput APIs for reading and
             :   writing 2D images that is format agnostic.
             : - Format plugins for TIFF, JPEG/JFIF, OpenEXR, PNG, HDR/RGBE, Targa, JPEG-2000,
             :   DPX, Cineon, FITS, BMP, ICO, RMan Zfile, Softimage PIC, DDS, SGI,
             :   PNM/PPM/PGM/PBM, Field3d.
             : - An ImageCache class that transparently manages a cache so that it can access
             :   truly vast amounts of image data.

Transaction Summary
Skip  1 Package

Nothing to do.
1 Like

Now it works i just had to wait till the update was ready.

I tried to understand and also made some change for the testing repositories, after redoing it, it got updated and the error desapierd.

As i understood @vgaetera 's link a dependencies of OpenImageIo had to be recompiled and shipped with an update.

1 Like

This looks like a known issue:

The relevant update:

1 Like

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.