Dnf update error with qt5-qtwebengine-freeworld-5.15.12-6.fc39.x86_64

Last week when I did dnf update, I got the following error. I waiting a week and tried again and it is still happening. Can you give me advice if this is something I should just keep waiting for the dependency to be resolved, or if I need to add/remove packages to resolve this?

Thanks.

Problem 1: package qt5-qtwebengine-freeworld-5.15.12-6.fc39.x86_64 from @System requires qt5-qtbase(x86-64) = 5.15.11, but none of the providers can be installed
  - cannot install both qt5-qtbase-5.15.12-1.fc39.x86_64 from updates and qt5-qtbase-5.15.11-7.fc39.x86_64 from @System
  - cannot install the best update candidate for package qt5-qtwebengine-freeworld-5.15.12-6.fc39.x86_64
  - cannot install the best update candidate for package qt5-qtbase-5.15.11-7.fc39.x86_64
 Problem 2: problem with installed package qt5-qtwebengine-freeworld-5.15.12-6.fc39.x86_64
  - package qt5-qtwebengine-freeworld-5.15.12-6.fc39.x86_64 from @System requires qt5-qtbase(x86-64) = 5.15.11, but none of the providers can be installed
  - package qt5-qtwebengine-freeworld-5.15.12-6.fc39.x86_64 from rpmfusion-free-updates requires qt5-qtbase(x86-64) = 5.15.11, but none of the providers can be installed
  - cannot install both qt5-qtbase-5.15.12-1.fc39.x86_64 from updates and qt5-qtbase-5.15.11-7.fc39.x86_64 from @System
  - package python3-qt5-base-5.15.10-2.fc39.x86_64 from updates requires qt5-qtbase(x86-64) = 5.15.12, but none of the providers can be installed
  - cannot install the best update candidate for package python3-qt5-base-5.15.9-7.fc39.x86_64

Here are the repos I have enabled:

repo id                                                                                                                  repo name
1password                                                                                                                1Password Stable Channel
copr:copr.fedorainfracloud.org:phracek:PyCharm                                                                           Copr repo for PyCharm owned by phracek
fedora                                                                                                                   Fedora 39 - x86_64
fedora-cisco-openh264                                                                                                    Fedora 39 openh264 (From Cisco) - x86_64
google-chrome                                                                                                            google-chrome
rpmfusion-free                                                                                                           RPM Fusion for Fedora 39 - Free
rpmfusion-free-updates                                                                                                   RPM Fusion for Fedora 39 - Free - Updates
rpmfusion-nonfree                                                                                                        RPM Fusion for Fedora 39 - Nonfree
rpmfusion-nonfree-nvidia-driver                                                                                          RPM Fusion for Fedora 39 - Nonfree - NVIDIA Driver
rpmfusion-nonfree-steam                                                                                                  RPM Fusion for Fedora 39 - Nonfree - Steam
rpmfusion-nonfree-updates                                                                                                RPM Fusion for Fedora 39 - Nonfree - Updates
updates                                                                                                                  Fedora 39 - x86_64 - Updates

I’m going to assume you enabled RPMFusion after you installed rather than during the installation itself. The first thing you should do is update all your installed groups, the only way that I’m aware of to do this is with $ dnf group list then for every group listed in the “installed” groups section do a $ sudo dnf group update *group*. Next you may just have to wait a little longer before the conflict is resolved. According to rpmfusion.org this usually happens because an update got pushed to Fedora stable while the corresponding rpmfusion update is still in testing(and in my experience this is usually the case). If you believe it’s taking too long you may just want to file a bug report to rpmfusion, but I don’t think that’s necessary for this situation.

You can remove qt5-qtwebengine-freeworld unless you’re using a Qt5-based web browser like Falkon. The package only adds support for patent-encumbered codecs to that engine.

Keep in mind that if you do “dnf groupupdate multimedia” again then you will get an error again.
To prevent this, you can add the command –exclude=qt5-qtwebengine-freeworld
Or add exclude=qt5-qtwebengine-freeworld to /etc/dnf/dnf.conf
Until RPM Fusion fixes it.

https://bugzilla.rpmfusion.org/show_bug.cgi?id=6851

1 Like