DNF isn't finding a package even though its listed on the fedora packages website

The website for vapoursynth says
“For Fedora, the VapourSynth packages can be downloaded from official repository directly.”

But trying to install the package “vapoursynth” on fedora 37 is giving me this error:

No match for argument: vapoursynth
Error: Unable to find a match: vapoursynth

I checked the fedora packages website to make sure and it shows up there

I also tried dnf search which returns this:

Name & Summary Matched: vapoursynth
python3-vapoursynth.x86_64 : Python interface for VapourSynth
vapoursynth-devel.i686 : Development files for vapoursynth
vapoursynth-devel.x86_64 : Development files for vapoursynth
vapoursynth-libs.x86_64 : VapourSynth’s core library with a C++ API
vapoursynth-libs.i686 : VapourSynth’s core library with a C++ API
vapoursynth-tools.x86_64 : Extra tools for VapourSynth

Subpackages show up but not the main package. Is this a bug or am I missing something obvious?

Aren’t you looking at the source package instead of the compiled packages?

Are you sure you don’t want one of these:


Oh, you are right. I guess I misunderstood how the packages site worked. One of those must be what I’m after. Thank you.

This particular package is an odd case. The src.fedoraproject.org site is organized by source package. Usually, there is a binary[1] package with the same name, and possibly one or more binary subpackages. But this package only has subpackages, no “main” binary package.

  1. “binary” is kind of a misnomer, but that’s the convention ↩︎