Could not connect to mail server the connection was refused

Try to open a email account (Protonmail) and error message is could not connect to mail server the connection was refused.
Do not know what causes this.

Hi @jpbn

You have left us hanging quite early … without sufficient information to help. speaks of the local machine (yours). Are you setting up an email server or are you trying to connect to the service provided by Protonmail?

If you are trying to access the later, then the error message may be saying that you do not have an internet connection … otherwise, you are trying to connect to a service that is running on your own machine.

1 Like

   I’m just clicked on the link in you post, and got exact same message: “Connection refused”.  Seems that Роскомнадзор not lifted the ban yet.  @jpbn, is censorship in you whereabouts is sane, or you’d just forget to connect to some proxy, like as me, today?
   Last time i checked, the Protonmail’ve had some instructions about setting up all of this.  Probably it’s even works without their app.

Thanks for yoyr answer,
I am using email from Protonmail with Bridge. Bridge uses Thunderbird to connect to email. Bridge uses to connect to Protonmail. And does not cooperate. We did change port numbers, but no succes there. We did follow the instructions of Protonmail Vits95 does mention.
Question: How many processes can use local host ( at the same time?
Error does not mention conflict of service.
Regards Jaap

Maybe there is some “mail service” that should be allowed in firewalld (idk)?

I have the same problem since the upgrade from 31 to 32. So far I activated firewalld logging but didn’t find anything in the journal. I tried the Flathub version as well as the official rpm and got the same error in Evolution as well as Thunderbird. ProtonMail Bridge doesn’t throw any error messages to stderr and the GUI looks like everything is working fine. Evolution and Thunderbird both say that the connection to is refused. Any ideas what else to try?

Hello qoheniac, nice to meet you.
did upgrade change localhost? http://localhost:8384/ ??
did you upgrade to new version of syncthing? dnf install …
did you ask ?

somehow a update did the thing, no problems on this.

Fedora 32 is up to date on all devices and I still have the problem. How is syncthing relevant? It’s not a dependency of the ProtonMail Bridge client and it’s not installed on any of my devices.

Both Proton Bridge and Syncthing use this so my guess was they did use the same port. I do have both on my PC. If two apps use u should give them different ports to use,
Thanks for asking.

I just updated ProtonMail Bridge to version 1.2.7 (official rpm) and now everything works fine again.

1 Like

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.