Correct way to enable mDNS on Fedora Server 34?

What is the correct way to enable responding to and resolution of *.local domain names on Fedora Server 34? (aka “Multicast DNS” or “mDNS”)

I already got this working, but I’m not confident I did it the recommended way. In my research I found a lot of confusing information about avahi-daemon, nss-mdns, systemd-resolved, systemd-networkd, /etc/nsswitch.conf, authselect, /etc/systemd/resolved.conf, NetworkManager, etc.

Anyway, the solution I went with was to:

  1. Set MulticastDNS=yes in /etc/systemd/resolved.conf.
  2. Create a file /etc/NetworkManager/conf.d/enable-mdns.conf with connection.mdns=2 set in the [connection] section.
  3. Reboot.

Q: What is the recommended way to enable mDNS resolver and responder on Fedora Server 34?


Additionally, I found that mDNS was working out the box on my Siverblue system. I wasn’t able to figure out what configuration option or package was making that happen in order to replicate it on my Fedora Server system. It didn’t have the configuration entries that I added to my Fedora Server system…

Q: What package or piece of configuration enables mDNS by default on Fedora Silverblue (and presumeably Workstation)?