Connecting bluetooth headphones doesn't switch audio to it

I am in a Microsot Teams meeting, I joined through Brave web browser.

Then I connect my headphones through Bluetooth. The headphones say “Bluetooth connected” and the menu in panel in the upper right corner shows headphones as connected.

But the audio is still playing through the PC speakers rather than my headphones :frowning:

How can I solve it?

Short-term solution:

  1. open system settings (from top right menu)
  2. switch to “Audio”
  3. select your headphones as output and/or input device

Which fedora version are you on?