Cockpit had an unexpected internal error - cockpit-389-ds

Hi everybody, i’ve recently installed two systems:
I have fedora 31 on both of them and cockpit-213-1.fc31.x86_64
A frontend where i put cockpit-213 interface to manage the backend through there, 2GB ram, 2 CPU, and no much more
A backend where i put cockpit213 as well as cockpit-389-ds to create instances in order to manage an ldap there, 4 GB RAM. 4 CPU

I’m using a proxy to get to the internet, i have no direct connection to the outside,
The problem occur when i get into the interface to manage the systems and update them,
dnf and yum work perfectly with proxy from within a terminal while the Software Updates within Cockpit does not work. It says for example:

cannot update repo ‘fedora-modular’: Cannot prepare internal mirrorlist: Curl error (7): Couldn’t connect to server for [Failed to connect to port 443: Connection refused]; Last error: Curl error (7): Couldn’t connect to server for [Failed to connect to port 443: Connection refused]

In every repo i have this happens, even if i try to disable this one, another one appear there

I tried to set the proxy in dnf.conf but without success,
I tried to set the proxy to the environment variables but without success
I tried also to set the proxy in the unit service without success,
among other things, but none of them work

Nothing let me see the graphical updates through the interface,

Besides that when i’m trying to create an instance in the Directory Server, to start the creation of the groups, users, etc

I can’t even create the instance, i’m actually receiving this error from a red sign saying “Ooops!”:

I don’t know if this has something related with the proxy as well but i tried all this procedure from my local pc with a direct connection to the internet and i had no problems there,

All help will be much appreciated,

Many thanks,

Just for the record, a similar problem has been reported for CentOS 8. See 0016587: Cockpit Software Updates does not honor proxy settings from /etc/dnf/dnf.conf - CentOS Bug Tracker