Cant install kernel package

Hello! When I try to update my system with sudo dnf upgrade it outputs

Last metadata expiration check: 0:08:30 ago on mån 29 aug 2022 14:37:45.
Error: 
 Problem 1: package kernel-modules-extra-5.17.12-300.fc36.x86_64 requires kernel-uname-r = 5.17.12-300.fc36.x86_64, but none of the providers can be installed
  - conflicting requests
 Problem 2: package kernel-5.17.12-300.fc36.x86_64 requires kernel-core-uname-r = 5.17.12-300.fc36.x86_64, but none of the providers can be installed
  - conflicting requests
(try to add '--skip-broken' to skip uninstallable packages)

and if I do sudo dnf upgrade --skip-broken I get the output:

Last metadata expiration check: 0:17:24 ago on mån 29 aug 2022 14:37:45.
Error: 
 Problem 1: package kernel-modules-extra-5.17.12-300.fc36.x86_64 requires kernel-uname-r = 5.17.12-300.fc36.x86_64, but none of the providers can be installed
  - conflicting requests
 Problem 2: package kernel-5.17.12-300.fc36.x86_64 requires kernel-core-uname-r = 5.17.12-300.fc36.x86_64, but none of the providers can be installed
  - conflicting requests

And since kernel-core-uname-r is provided by kernel-core I tried to do sudo dnf install kernel-core , but when I do I get the output:

Package kernel-core-5.17.9-300.fc36.x86_64 is already installed.
Package kernel-core-5.17.12-300.fc36.x86_64 is already installed.
Package kernel-core-5.17.14-300.fc36.x86_64 is already installed.
Package kernel-core-5.18.6-200.fc36.x86_64 is already installed.

To me it seems like I have the right dependencies,I don’t really know where to go from here. Any help or pointers in the right direction would be much appreciated. If there is any more information I can provide to make it easier to diagnose I’d be more than happy to provide that. Thanks you in advance!

It looks like the same issue as this other thread:

4 Likes

I recently also ran into this issue on Fedora 37 running dnf update --skip-broken:

Error:
Problem 1: package kernel-modules-extra-6.0.16-300.fc37.x86_64 requires kernel-uname-r = 6.0.16-300.fc37.x86_64, but none of the providers can be installed

  • conflicting requests
    Problem 2: package kernel-6.0.16-300.fc37.x86_64 requires kernel-core-uname-r = 6.0.16-300.fc37.x86_64, but none of the providers can be installed
  • conflicting requests

I was running the kernel version 6.1.15-200, so removing all the previous (unused) kernel packages (kernel-core, kernel-modules) fixed this issue.

1 Like