Can't do background blur in Meet after removing Nvidia drivers

Tried nvidia drivers from rpm fusion on Fedora 35, got black screen after kernel upgrade, removed drivers. Now Google Meet on Chrome complains it can’t do any visual effects, same for Firefox.

I was able to do background blur just fine before installing the nvidia drivers.

Report from chrome://gpu:

Use hardware acceleration is on in Chrome.

I did try put the nvidia drivers back on, but still got black screen.

Upgraded to F36, no change.

You have to use the nvidia drivers with nvidia GPU to enable hardware acceleration.

This implies we need more info to solve the black screen issue so the driver is working well before you move on to the special effects.

Please post the output of dnf repolist and inxi -Fzx in preformatted text </> tags so we can tell which GPU is installed and which repo the driver would be installed from

1 Like
repo id                                                            repo name
docker-ce-stable                                                   Docker CE Stable - x86_64
fedora                                                             Fedora 36 - x86_64
fedora-cisco-openh264                                              Fedora 36 openh264 (From Cisco) - x86_64
fedora-modular                                                     Fedora Modular 36 - x86_64
gh-cli                                                             packages for the GitHub CLI
google-chrome                                                      google-chrome
phracek-PyCharm                                                    Copr repo for PyCharm owned by phracek
rpmfusion-free                                                     RPM Fusion for Fedora 36 - Free
rpmfusion-free-updates                                             RPM Fusion for Fedora 36 - Free - Updates
rpmfusion-nonfree                                                  RPM Fusion for Fedora 36 - Nonfree
rpmfusion-nonfree-nvidia-driver                                    RPM Fusion for Fedora 36 - Nonfree - NVIDIA Driver
rpmfusion-nonfree-steam                                            RPM Fusion for Fedora 36 - Nonfree - Steam
rpmfusion-nonfree-updates                                          RPM Fusion for Fedora 36 - Nonfree - Updates
updates                                                            Fedora 36 - x86_64 - Updates
updates-modular                                                    Fedora Modular 36 - x86_64 - Updates
  Kernel: 5.18.16-200.fc36.x86_64 arch: x86_64 bits: 64 compiler: gcc
    v: 2.37-27.fc36 Desktop: GNOME v: 42.3.1
    Distro: Fedora release 36 (Thirty Six)
  Type: Desktop System: Gigabyte product: Z97MX-Gaming 5 v: N/A
    serial: <superuser required>
  Mobo: Gigabyte model: Z97MX-Gaming 5 v: x.x serial: <superuser required>
    UEFI: American Megatrends v: F6 date: 09/18/2015
  Device-1: hidpp_battery_0 model: Logitech G603 Wireless Gaming Mouse
    charge: 100% (should be ignored) status: discharging
  Info: quad core model: Intel Core i5-4690 bits: 64 type: MCP arch: Haswell
    rev: 3 cache: L1: 256 KiB L2: 1024 KiB L3: 6 MiB
  Speed (MHz): avg: 994 high: 1378 min/max: 800/3900 cores: 1: 1378 2: 1000
    3: 800 4: 800 bogomips: 28001
  Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
  Device-1: Intel Xeon E3-1200 v3/4th Gen Core Processor Integrated Graphics
    vendor: Gigabyte driver: i915 v: kernel arch: Gen5.75 bus-ID: 00:02.0
  Device-2: NVIDIA GP106 [GeForce GTX 1060 6GB] vendor: Gigabyte
    driver: nouveau v: kernel arch: Pascal bus-ID: 01:00.0
  Device-3: Logitech HD Webcam B910 type: USB
    driver: snd-usb-audio,uvcvideo bus-ID: 3-4:2
  Display: x11 server: X.Org v: 1.20.14 with: Xwayland v: 22.1.3 driver: X:
    loaded: modesetting unloaded: fbdev,vesa gpu: nouveau resolution: 2560x1440
  OpenGL: renderer: NV136 v: 4.3 Mesa 22.1.4 direct render: Yes
  Device-1: Intel Xeon E3-1200 v3/4th Gen Core Processor HD Audio
    driver: snd_hda_intel v: kernel bus-ID: 3-4:2
  Device-2: Intel 9 Series Family HD Audio vendor: Gigabyte
    driver: snd_hda_intel v: kernel bus-ID: 00:1b.0
  Device-3: NVIDIA GP106 High Definition Audio vendor: Gigabyte
    driver: snd_hda_intel v: kernel bus-ID: 01:00.1
  Device-4: Logitech HD Webcam B910 type: USB
    driver: snd-usb-audio,uvcvideo
  Device-5: JMTek LLC. USB PnP Audio Device type: USB
    driver: hid-generic,snd-usb-audio,usbhid bus-ID: 3-9:4
  Sound Server-1: ALSA v: k5.18.16-200.fc36.x86_64 running: yes
  Sound Server-2: PulseAudio v: 15.0 running: no
  Sound Server-3: PipeWire v: 0.3.56 running: yes
  Device-1: Qualcomm Atheros Killer E220x Gigabit Ethernet vendor: Gigabyte
    driver: alx v: kernel port: d000 bus-ID: 03:00.0
  IF: enp3s0 state: up speed: 1000 Mbps duplex: full mac: <filter>
  IF-ID-1: br-4ce2ffb218dd state: down mac: <filter>
  IF-ID-2: br-ab9890ca735a state: down mac: <filter>
  IF-ID-3: br-c0037e63026e state: down mac: <filter>
  IF-ID-4: br-d742c740f43e state: down mac: <filter>
  IF-ID-5: br-f3f2874d9243 state: up speed: 10000 Mbps duplex: unknown
    mac: <filter>
  IF-ID-6: docker0 state: down mac: <filter>
  IF-ID-7: veth724b4ea state: up speed: 10000 Mbps duplex: full
    mac: <filter>
  IF-ID-8: virbr0 state: down mac: <filter>
  Local Storage: total: 6.48 TiB used: 581.66 GiB (8.8%)
  ID-1: /dev/sda vendor: Samsung model: SSD 850 EVO 500GB size: 465.76 GiB
  ID-2: /dev/sdb vendor: Western Digital model: WD20EZRZ-00Z5HB0
    size: 1.82 TiB
  ID-3: /dev/sdc vendor: Samsung model: SSD 850 EVO M.2 120GB
    size: 111.79 GiB
  ID-4: /dev/sdd vendor: Samsung model: Portable SSD T3 size: 465.76 GiB
  ID-5: /dev/sde type: USB vendor: Toshiba model: EXTERNAL USB
    size: 3.64 TiB
  ID-1: / size: 87.88 GiB used: 69.11 GiB (78.6%) fs: btrfs dev: /dev/dm-0
    mapped: luks-9d4248ba-e6bf-4575-804d-45f287c697c8
  ID-2: /boot size: 973.4 MiB used: 253.9 MiB (26.1%) fs: ext4
    dev: /dev/sdc2
  ID-3: /boot/efi size: 598.8 MiB used: 14 MiB (2.3%) fs: vfat
    dev: /dev/sdc1
  ID-4: /home size: 87.88 GiB used: 69.11 GiB (78.6%) fs: btrfs
    dev: /dev/dm-0 mapped: luks-9d4248ba-e6bf-4575-804d-45f287c697c8
  ID-1: swap-1 type: zram size: 8 GiB used: 0 KiB (0.0%) dev: /dev/zram0
  System Temperatures: cpu: 34.0 C mobo: N/A gpu: nouveau temp: 50.0 C
  Fan Speeds (RPM): N/A gpu: nouveau fan: 0
  Processes: 312 Uptime: 7h 12m Memory: 31.15 GiB used: 4.57 GiB (14.7%)
  Init: systemd target: graphical (5) Compilers: gcc: 12.1.1 Packages: 6
  note: see --pkg Shell: Bash v: 5.1.16 inxi: 3.3.19

I see that you have both rpmfusion-nonfree and rpmfusion-nonfree-nvidia-driver repos enabled.

To do a clean install of the nvidia drivers from rpmfusion please do the following.

  1. dnf remove *nvidia*
  2. dnf install akmod-nvidia*515* xorg-x11-drv-nvidia-cuda*515* --disablerepo=rpmfusion-nonfree
  3. Wait 5 minutes then reboot.
    If you have secure boot enabled this might not enable the nvidia driver. To check that
  4. lsmod | grep nvidia
    which should give a list of loaded nvidia modules. If not and/or if you still get the black screen, then when powering on go into your bios and disable secure boot then try again.

Thanks. I’ll give that a go. It bothers me that it’s not working without the nvidia driver when it was working just fine before I installed it.

Hardware acceleration does not work on most newer nvidia cards when using the open source nouveau driver. That is a fact that is inescapable.

You may have been able to use the enhanced features of the software, but at the cost of cpu load doing software video rendering and slower video response.

1 Like

So I ran the commands you suggested. Black screen again. My BIOS menu doesn’t have a secureboot on/off setting but it allows you to choose “Legacy” or “UEFI” for the boot menu. I had both on and so there’s two entries for the fedora partition in the boot menu, both led to a black screen.

Please post the output of dmesg | grep -iE 'secure|nvidia|nouveau just after booting as well as dnf list installed *nvidia* and cat /etc/default/grub

If you have a setting for UEFI then it is almost certain there is an option to disable secure boot under the security tab in the bios. It may be one or more levels down in the selections.

Sorry for taking a while to respond.

I’m not sure how, but I’m certain Secure Boot is disabled.

$ mokutil --sb-state
SecureBoot disabled
Platform is in Setup Mode

I went through the process of trying the drivers again. Same issue. I then edited the grub line to get back to nouveau and then ran your commands.

$ dmesg | grep -iE 'secure|nvidia|nouveau'

$ dnf list installed *nvidia*
Installed Packages
akmod-nvidia.x86_64                                                                          3:515.65.01-1.fc36                                                     @rpmfusion-nonfree-updates
kmod-nvidia-5.19.8-200.fc36.x86_64.x86_64                                                    3:515.65.01-1.fc36                                                     @@commandline             
nvidia-gpu-firmware.noarch                                                                   20220815-138.fc36                                                      @updates                  
nvidia-settings.x86_64                                                                       3:515.65.01-1.fc36                                                     @rpmfusion-nonfree-updates
xorg-x11-drv-nvidia.x86_64                                                                   3:515.65.01-1.fc36                                                     @rpmfusion-nonfree-updates
xorg-x11-drv-nvidia-cuda-libs.x86_64                                                         3:515.65.01-1.fc36                                                     @rpmfusion-nonfree-updates
xorg-x11-drv-nvidia-kmodsrc.x86_64                                                           3:515.65.01-1.fc36                                                     @rpmfusion-nonfree-updates
xorg-x11-drv-nvidia-libs.i686                                                                3:515.65.01-1.fc36                                                     @rpmfusion-nonfree-updates
xorg-x11-drv-nvidia-libs.x86_64                                                              3:515.65.01-1.fc36                                                     @rpmfusion-nonfree-updates
xorg-x11-drv-nvidia-power.x86_64                                                             3:515.65.01-1.fc36                                                     @rpmfusion-nonfree-updates
$ cat /etc/default/grub
GRUB_DISTRIBUTOR="$(sed 's, release .*$,,g' /etc/system-release)"
GRUB_CMDLINE_LINUX="rd.driver.blacklist=nouveau modprobe.blacklist=nouveau nvidia-drm.modeset=1 initcall_blacklist=simpledrm_platform_driver_init rd.luks.uuid=luks-9d4248ba-e6bf-4575-804d-45f287c697c8 rhgb quiet rd.driver.blacklist=nouveau modprobe.blacklist=nouveau nvidia-drm.modeset=1 initcall_blacklist=simpledrm_platform_driver_init"

Not sure if related, but running Chrome now crashes the desktop and I have to relogin. If I start it with --disable-gpu, then it’s fine.