Can't crate toolbox containers

For the last day or two, I haven’t been able to crate containers using fedora-toolbox (toolbox create). It keeps failing to pull the image. This is the case on both my Fedora 29 Workstation desktop and Fedora Silverblue 30 Laptop. On both, I have also tried other --release flags, but that won’t work either.

Does anyone know what is going on? toolbox is something I’m very excited about, as I think it is one of the last big things I need for using Silverblue on my main devices…


You may have hit, which will be fixed in a podman update soon-ish.

Thanks. It looks like those fixes were added to 0.0.8 of toolbox. How can I see which version of a package I have with rpm-ostree? (I don’t think toolbox has a version print out that I can see…_

Try rpm -qi toolbox. (As a workaround you can pass a different container name to the create command IIRC.)

Yea, it looks like I’m running 0.0.7. We’ll see if things are fixed when 0.0.8 hits. I tried running with the --container flag, but that didn’t do anything to help. I think the issue is coming from trying to pull down the image, rather than create the actual container name.

Regardless, I was able to grab the 0.0.8 build and manually try it on my Fedora 29 WS. It fixed my problem there, so I’m assuming it should work on the Silverblue laptop once it hits there.

Thanks for the help :slight_smile:

1 Like