Can't boot after update to kernel v6.3.4

On an Apple iMac14,2,
I can’t boot anymore after Fedora 38 updated to kernel v6.3.4. There is a freezed dark screen after the Fedora logo loader.

I can boot with previous kernel version (6.2.15).

When I boot in rescue mode, it says :

Press Enter to continue.

Reloading system manager configuration

[FAILED] Failed to mount boot-efi.mount - /boot/efi.
[DEPEND] Dependency failed for - Local File System.
[DEPEND] Dependency failed for selinux -autorelabel-marke.service - Mark the need to relabel after reboot.
[FAILED] Failed to mount proc-sys-fs-binfmt_misc.mount - Arbitrary Executable File Formats File System.
[FAILED] Failed to start systemd-binfmt.service - Set Up Additional Binary Formats.

What can I do to fix it?

Thank you

Same problem after kernel updated to v6.3.5 this morning

Are you using the nvidia drivers?

At the black screen can you use ctrl alt F3 to access a console login?

If so you may want to login and take a look at journalctl -b and see if there are any errors.


Might be the same:

1 Like

I had a similar issue with my system when I installed kernel 6.3.4.
I found the issue was caused by an option in the kernel command line.

With trouble shooting and trial & error I found that this command line works for me.

GRUB_CMDLINE_LINUX="rd.driver.blacklist=nouveau modprobe.blacklist=nouveau nvidia-drm-modeset=1 initcall_blacklist=simpledrm_platform_driver_init"

While the previous command line that had worked for several kernels (all the way back to the early 5.X kernels) failed and caused the hang noted. That line was:

GRUB_CMDLINE_LINUX="rd.driver.blacklist=nouveau modprobe.blacklist=nouveau nvidia-drm-modeset=1 initcall_blacklist=simpledrm_platform_driver_init kvm_ignore_msrs=1"

Note that the removal of the kvm_ignore_msrs=1 was what fixed booting for me.
The system failed to complete the boot and hung as noted with the underscore on screen before that option was removed.

In the troubleshooting process I had also removed the initcall_blacklist option and that allowed the boot but only displayed a grey screen and never got to the login screen. My final functional command line is as noted above. (Tested by editing the command line from the grub menu, made permanent by editing /etc/default/grub then running grub2-mkconfig -o /boot/grub2/grub.cfg)

Especially people with nvidia might try the kernel fix:

If the feedback indicates that this fix works, it might end up in the next Fedora kernel or the one after that.

Hello Chris,
Sorry I don’t have time to try the kernel fix right now. Will do later.

Just in case, here is the pastebin of sudo journalctl -r --boot=-1
pwd: Q17MaYVkPn

Thank you

@francoisromain your logs indicate that you have nvidia.

I suggest to try the experimental kernel with the fix before putting time in deeper analysis of the logs.

Please read the instructions on the other topic before doing that.

1 Like

Hello Joe,

Removing the nvidia drivers fixed the problem !
Thank you

From kernel 6.2.15:

❯ sudo dnf remove xorg-x11-drv-nvidia-470xx akmod-nvidia-470xx xorg-x11-drv-nvidia-470xx-cuda
Dependencies resolved.
 Package                                                                                      Architecture                                               Version                                                                 Repository                                                                              Size
 akmod-nvidia-470xx                                                                           x86_64                                                     3:470.182.03-2.fc38                                                     @rpmfusion-nonfree-nvidia-driver                                                        85 k
 xorg-x11-drv-nvidia-470xx                                                                    x86_64                                                     3:470.182.03-1.fc38                                                     @rpmfusion-nonfree-updates-testing                                                      55 M
 xorg-x11-drv-nvidia-470xx-cuda                                                               x86_64                                                     3:470.182.03-1.fc38    
Removing dependent packages:
 kmod-nvidia-470xx-6.2.15-300.fc38.x86_64                                                     x86_64                                                     3:470.182.03-2.fc38                                                     @@commandline                                                                           24 M
 kmod-nvidia-470xx-6.3.4-201.fc38.x86_64                                                      x86_64                                                     3:470.182.03-2.fc38                                                     @@commandline                                                                           25 M
 kmod-nvidia-470xx-6.3.5-200.fc38.x86_64                                                      x86_64                                                     3:470.182.03-2.fc38                                                     @@commandline                                                                           25 M
Removing unused dependencies:
 egl-wayland                                                                                  x86_64                                                     1.1.11-3.fc38                                                           @updates                                                                                71 k
 nvidia-persistenced                                                                          x86_64                                                     3:530.41.03-1.fc38                                                      @rpmfusion-nonfree                                                                      51 k
 nvidia-settings-470xx                                                                        x86_64                                                     3:470.182.03-1.fc38                                                     @rpmfusion-nonfree-updates-testing                                                     4.4 M
 opencl-filesystem                                                                            noarch                                                     1.0-17.fc38                                                             @fedora                                                                                  0  
 xorg-x11-drv-nvidia-470xx-cuda-libs                                                          x86_64                                                     3:470.182.03-1.fc38                                                     @rpmfusion-nonfree-updates-testing                                                     135 M
 xorg-x11-drv-nvidia-470xx-kmodsrc                                                            x86_64                                                     3:470.182.03-1.fc38                                                     @rpmfusion-nonfree-updates-testing                                                      24 M
 xorg-x11-drv-nvidia-470xx-libs                                                               x86_64                                                     3:470.182.03-1.fc38                                                     @rpmfusion-nonfree-updates-testing                                                     322 M

Transaction Summary
Remove  13 Packages

Freed space: 618 M

reboot, then:

❯ uname -r



If the default driver works for you and fulfills your needs, I indeed suggest to use the default instead of the proprietary nvidia driver → more stability/security given the holistic development and testing in and around the kernel.

However, in case that you will install nvidia drivers again in future: I see that you installed the drivers manually, which means they do not get updates at all. This can cause itself issues over time (stability and security, but also compatibility). You should not do that but instead use a repository with the nvidia driver → usually people use rpmfusion for that (which you seem to already have).

However, I see you have rpmfusion-testing repositories enabled. Be aware that these are, as the name suggests, testing and not yet stable :wink: So if you use your system for “production” purposes, I suggest to use the stable repositories.


Thank you for the explanation.

I guess, I was using the test repo because I installed Fedora 38 in beta. I didn’t change after the release.

I suspect the mixture of repos as well as versions was the issue with the nvidia drivers. I think that if one were to disable the nvidia-nonfree-testing repo then reinstall the nvidia 470xx driver from the rpmfusion-nonfree-nvidia-drivers repo things would work properly

I have an iMac 14,2 and normally use nouveau and Wayland. I tried akmod-nvidia-470xx from rpmfusion-nonfree when I first installed F38, but went back to nouveau.\ with Wayland.

Today, with 6.3.5-200, I tried akmod-nvidia-470xx again. First boot went to a nearly black screen with grey across the top 1/3.

Interesting entries in journalctl:

Jun 06 14:16:39 fedorausb kernel: nvidia: module license 'NVIDIA' taints kernel.
Jun 06 14:16:39 fedorausb kernel: Disabling lock debugging due to kernel taint
Jun 06 14:16:42 fedorausb /usr/libexec/gdm-x-session[1258]: (II) NOUVEAU driver for NVIDIA chipset families :
Jun 06 14:16:42 fedorausb kernel: NVRM: loading NVIDIA UNIX x86_64 Kernel Module  470.182.03  Fri Feb 24 03:29:56 UTC 2023
Jun 06 14:16:43 fedorausb /usr/libexec/gdm-x-session[1258]: (II) modeset(0): Refusing to try glamor on llvmpipe
Jun 06 14:16:43 fedorausb /usr/libexec/gdm-x-session[1258]: (EE) modeset(0): glamor initialization failed
Jun 06 14:16:43 fedorausb kernel: nvidia-modeset: Loading NVIDIA Kernel Mode Setting Driver for UNIX platforms  470.182.03  Fri Feb 24 03:18:06 UTC 2023
Jun 06 14:16:43 fedorausb kernel: [drm] [nvidia-drm] [GPU ID 0x00000100] Loading driver

Then I tried adding initcall_blacklist=simpledrm_platform_driver_initto the kernel command line. The system boots and is running Xorg (Wayland is not on offer).

I also found the initcall_blacklist=simpledrm_platform_driver_init was mandatory on my system for use with nvidia.

The 470xx and all older drivers do not support wayland.

Exactly the problem I experienced with akmod-nvidia-470xx.

The only reason I used this driver was because it worked better with my second screen (apple thunderbolt display). With the nouveau drivers, the second screen is off after a reboot. I have to go to the gnome settings to toggle it back on.

Anyway, now he akmod drivers are buggy with 6.3 kernels, I’ll stay on the nouveau drivers.

2 posts were split to a new topic: Nvidia and default drivers: stability? Security? … and relation to market shares of hardware?