Cannot start TexStudio

I have installed TexStudio from the repositories but I cannot start it:

$ texstudio
texstudio: error while loading shared libraries: cannot open shared object file: No such file or directory

Solved it by

sudo dnf install qt5-qtscript

I don’t know why this is not a dependency :wink:


Good to know you solved your problem Glad for you if you would like or have time to report the problem to redhat Bugzilla

And notify the developer to modify the rpm. spec to add it at dependency.


Actually, the developer/maintainer shouldn’t need to add this runtime dependency (“Requires:”), as rpmbuild usually does this automatically by inspecting the binaries for required libraries.

In fact, for the current F34 package, this seems to have worked correctly:
$ rpm -qp --requires texstudio-3.1.1-1.fc34.x86_64.rpm | grep
$ sudo dnf repoquery --whatprovides “”

At least for this package, all seems correctly in place. Either some older version (or the F33 build) had a glitch, or the original poster managed to remove qt5-qtscript although installed packages require it.


This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.