Cannot get monitors to extend

I did an in place upgrade to Fedora 38 and I am having a problem with two monitors. Before the upgrade I would extend the monitors to have two places to work. Now the monitors duplicate and the extend is not available. The Display section in System settings only shows one monitor. I have a Radeon RX580 Pro graphics card. What more information will you need to help me? Please list the commands with the options you want.
Here is part of the output from inxi -Fzxx
Device-1: AMD Ellesmere [Radeon RX 470/480/570/570X/580/580X/590]
vendor: XFX Pine driver: N/A arch: GCN-4 pcie: speed: 8 GT/s lanes: 8
bus-ID: 4b:00.0 chip-ID: 1002:67df
Device-2: Logitech Webcam C250 driver: snd-usb-audio,uvcvideo type: USB
rev: 2.0 speed: 480 Mb/s lanes: 1 bus-ID: 3- chip-ID: 046d:0804
Display: x11 server: X.Org v: 1.20.14 with: Xwayland v: 22.1.9
compositor: kwin_x11 driver: X: loaded: vesa
unloaded: fbdev,modesetting,radeon dri: swrast gpu: N/A display-ID: :0
screens: 1
Screen-1: 0 s-res: 1920x1080 s-dpi: 92
Monitor-1: default res: 1920x1080 size: N/A
API: EGL v: 1.5 platforms: device: 0 drv: swrast surfaceless: drv: swrast
x11: drv: swrast inactive: gbm,wayland
API: OpenGL v: 4.5 vendor: mesa v: 23.1.8 glx-v: 1.4 es-v: 3.2
direct-render: yes renderer: llvmpipe (LLVM 16.0.6 256 bits)
device-ID: ffffffff:ffffffff
API: Vulkan v: 1.3.243 surfaces: xcb,xlib device: 0 type: cpu
driver: mesa llvmpipe device-ID: 10005:0000

that should be amdgpu not vesa

But I’m not sure how to diagnose why it isn’t amdgpu

If I were in that situation, one place I’d look would be

journalctl -b | less

then type /amdgpu to see if it was mentioned and if so, to see any plausible looking error messages near a mention of amdgpu

Another thing you might search for in the same journal output is 4b:00.0. That should be mentioned around the point it ought to load amdgpu. Unfortunately, 4b:00.0 probably also gets mentioned several times before the right point. So you may need to look at a bunch of places in the journal to see if it is telling you what is wrong.

This shows no driver for the GPU. thus vesa and llvmpipe is managing the display.

I am not sure how I fixed it. I added two modprobes - one to authorize amdgpu and one to blacklist radeon. One post I looked at said to make sure card was authorized in BIOS. As I was looking through the BIOS, i saw that something called Thunderbolt was enabled. No idea what it is so I disabled it and rebooted. Everything worked as expected. I am not sure which fixed it but it is now working.
This can be closed as fixed.
Vincent Radice

Thunderbolt seems a way of sending video via certain usb C ports. Or rather is the mac equivalent of usb C but faster. It may have been interfering. A quick google will provide info about it.