Cannot get Fedora 32 to use the amdgpu driver for navi 14 graphics

I bought a MSI Bravo 15 laptop and it comes with the Ryzen 7 4000 series processor with an RX5500m graphics processor. It keeps loading the llvmpipe drivers, so graphics acceleration doesnt work, or works extreamly poorly. Can anyone tell me how make the system use the amdgpu drivers? Im at a loss and google searches have turned up nothing but grub entries for older card series.

$ inxi -G
Graphics:  Device-1: Advanced Micro Devices [AMD/ATI] Navi 14 [Radeon RX 5500/5500M / Pro 5500M] driver: N/A 
           Device-2: Advanced Micro Devices [AMD/ATI] Renoir driver: N/A 
           Display: x11 server: Fedora Project 1.20.8 driver: ati unloaded: fbdev,modesetting,radeon 
           resolution: 1920x1080~77Hz 
           OpenGL: renderer: llvmpipe (LLVM 10.0.0 256 bits) v: 3.3 Mesa 20.1.2 
$ lspci -v

08:00.0 VGA compatible controller: Advanced Micro Devices, Inc. [AMD/ATI] Renoir (rev c6) (prog-if 00 [VGA controller])
	Subsystem: Micro-Star International Co., Ltd. [MSI] Device 12b5
	Flags: bus master, fast devsel, latency 0, IRQ 255
	Memory at b0000000 (64-bit, prefetchable) [size=256M]
	Memory at c0000000 (64-bit, prefetchable) [size=2M]
	I/O ports at e000 [disabled] [size=256]
	Memory at fe300000 (32-bit, non-prefetchable) [size=512K]
	Capabilities: [48] Vendor Specific Information: Len=08 <?>
	Capabilities: [50] Power Management version 3
	Capabilities: [64] Express Legacy Endpoint, MSI 00
	Capabilities: [a0] MSI: Enable- Count=1/4 Maskable- 64bit+
	Capabilities: [c0] MSI-X: Enable- Count=4 Masked-
	Capabilities: [100] Vendor Specific Information: ID=0001 Rev=1 Len=010 <?>
	Capabilities: [270] Secondary PCI Express
	Capabilities: [2b0] Address Translation Service (ATS)
	Capabilities: [2c0] Page Request Interface (PRI)
	Capabilities: [2d0] Process Address Space ID (PASID)
	Capabilities: [400] Data Link Feature <?>
	Capabilities: [410] Physical Layer 16.0 GT/s <?>
	Capabilities: [440] Lane Margining at the Receiver <?>
	Kernel modules: amdgpu



dmesg contains:

$ dmesg | grep amd
[    0.812462] amd_uncore: AMD NB counters detected
[    0.812464] amd_uncore: AMD LLC counters detected
[    0.813946] perf/amd_iommu: Detected AMD IOMMU #0 (2 banks, 4 counters/bank).
[    1.839601] [drm:amdgpu_init [amdgpu]] *ERROR* VGACON disables amdgpu kernel modesetting.
[    1.887150] [drm:amdgpu_init [amdgpu]] *ERROR* VGACON disables amdgpu kernel modesetting.
[   66.138340] [drm:amdgpu_init [amdgpu]] *ERROR* VGACON disables amdgpu kernel modesetting.
[   66.373065] [drm:amdgpu_init [amdgpu]] *ERROR* VGACON disables amdgpu kernel modesetting.

nomodeset is on the grub boot command, removing it results in either failing to boot or going to a black screen on login.

I can add

GRUB_CMDLINE_LINUX_DEFAULT= radeon.si_support=0 radeon.cik_support=0 amdgpu.si_support=1 amdgpu.cik_support=1 amdgpu.dc=1 amdgpu.dpm=1 amdgpu.modeset=1

and it boots to the GDM login screen but freezes…no mouse movement or keyboard actions recognized. This happened on the live install disc as well.

I have same laptop model and same issue with Plasma spin. Tried with the grub option amdgpu.dc=0 ( and freezes at login screen.

Removing nomodeset and adding amdgpu.runpm=0 solves hangs and freezes. Update your BIOS as well.


1 Like

I diddnt realize this post had been replied to. For anyone else crossing this post I tried again a few months later and kernel updates had resolved the issue.

FYI - Fedora 32 is very end of life. I strongly recommend upgrading to Fedora 34 and then consider upgrading to 35 from there (only up to two versions at a time are supported for upgrades). There have been a ton of improvements with the amdgpu driver in recent kernels, so you’ll likely have a better experience overall after upgrading.

Ya, if memory serves it was the Fedora 33 update that fixed it…but it has been a too long for me to remember accurately. I keep up to date with latest releases.

1 Like