Can not connect to pptp vpn

Hey guys, I am new to Fedora.
I Installed Fedora 32 64 bit, with gnome desktop. After installation I upgrade my Fedora and there was not any error, but now when I want to connect to pptp vpn by gui client, it won’t happend and also when I run sudo dnf update or sudo dnf upgrade I face these errors:

If any one can help me I will appreciate it. Thanks a lot.

1 Like

You should probably not use a third-party pptp client. This is all baked into Gnome’s Network Manager

sudo dnf search pptp

sudo dnf install pptp NetworkManager-pptp-gnome

will nicely integrate VPN functionality into Gnome.

Delete those other repos!


You’d best avoid using PPTP as the protocol is widely insecure due to multiple vulnerabilities.
The recommended solutions are WireGuard, OpenVPN and IPsec implementations.


Thanks a lot! I deleted those repos and my update problem solved, after that I install NetworkManagaer-pptp-gnome, but I still couldn,t connect, I also tried all of the packages with pptp search brought to me, it still didn’t connect!
Do you know what should I do next? Thanks.

Thanks for your warning, I am aware of that but I just can use pptp to connect to my office network, but surely I will talk about it to my manager, to make it right.
Thanks a lot.

1 Like

Start collecting logs:

journalctl -f

And try to activate the connection.

1 Like

I done this, this is the result:

I serach it and there was a reccomendation:
modprobe nf_conntrack_pptp
I execute it but nothing happend.
Another one was:
sudo nano /etc/modules-load.d/pptp.conf
#Load nf_conntrack_pptp module at boot
I have tried it and nothing happend again!

1 Like

Does any one knows how should I solve this issue?
I search the, these two solutions was proposed:

  1. modprobe nf_conntrack_pptp
  2. sudo nano /etc/modules-load.d/pptp.conf
    #Load nf_conntrack_pptp module at boot
    Unfortunately I past the exact code in my terminal, then try to connect to pptp vpn, it still won’t work!
    I’ll be appreciate your help. Thanks.

Could you try this solution?


Thanks a lot! That was the solution! You made a big favor to me!
Good Luck!

1 Like

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.