BTRFS size mismatch due to failed resizing

A month ago, I tried to resize my system BTRFS partition. It failed to resize but mounted without issue so I didn’t care much.

However, I later found out that btrfs assistant is showing a smaller size than the partition size, a size that matches the resize I tried to do before. How can I fix this? There is no apparent problem now, but this may be a time bomb and I don’t want it triggering when I least expect it.

Relevant info:

NAME                                          MAJ:MIN RM   SIZE RO TYPE  MOUNTPOINTS
sda                                             8:0    0 931.5G  0 disk  
├─sda1                                          8:1    0 531.5G  0 part  /mnt/sda1
└─sda2                                          8:2    0   400G  0 part  
  └─luks-<uuid>                            253:1    0   400G  0 crypt /mnt/dm-1
sr0                                            11:0    1  1024M  0 rom   
zram0                                         252:0    0   7.6G  0 disk  [SWAP]
nvme0n1                                       259:0    0 232.9G  0 disk  
├─nvme0n1p1                                   259:1    0   600M  0 part  /boot/efi
├─nvme0n1p2                                   259:2    0     1G  0 part  /boot
└─nvme0n1p3                                   259:3    0 231.3G  0 part  
  └─luks-<uuid>                                  253:0    0 231.3G  0 crypt /home

df -h
Filesystem      Size  Used Avail Use% Mounted on
devtmpfs        4.0M     0  4.0M   0% /dev
tmpfs           3.9G     0  3.9G   0% /dev/shm
tmpfs           1.6G  1.8M  1.6G   1% /run
/dev/dm-0       182G   22G  159G  12% /
/dev/dm-0       182G   22G  159G  12% /home
tmpfs           3.9G     0  3.9G   0% /tmp
/dev/nvme0n1p2  974M  278M  629M  31% /boot
/dev/nvme0n1p1  599M   14M  585M   3% /boot/efi
/dev/sda1       523G   30G  466G   6% /mnt/sda1
/dev/dm-1       393G   29G  344G   8% /mnt/dm-1
tmpfs           783M  104K  783M   1% /run/user/1000

Notice the size of /dev/dm-0 and /dev/nvme0n1p3.

Found the solution:
sudo btrfs fi resize max /
Can be run without unmounting the partition.
I think my problem was that the broken resize operation instructed btrfs to change the max size it knows about, but failed to resize the partition.