Broadcom BCM4377b wifi card not working

I am trying to setup Fedora on a 2019 MBP (15,4), sadly, the wifi is not working. I have tried installing Broadcom-wl, but even with it installed it does not work. From more research I discovered that I needed the Brcmfmac Driver, but I do not know how to install it.
Edit: It seems as if the wifi card works fine on ubuntu, and debian based systems but I am not sure. If someone can help confirm this, it would be much appreciated.

1 Like

For making Broadcom devices work, I would try enabling the free and nonfree RPM Fusion repositories and installing the broadcom-wl package.

See Configuration - RPM Fusion and Installing broadcom wifi drivers - #2 by augenauf

Already did that, as stated in the original topic.

Oh my, I’m terribly sorry, I must have skipped a sentence.

Have you tried this custom kernel with the T2 patches? It seems like that your laptop should be supported: GitHub - mikeeq/mbp-fedora-kernel

It seems like the patch from the T2Linux kernel was actually upstreamed into kernel 6.3, see wifi: brcmfmac: pcie: Add IDs/properties for BCM4377 · torvalds/linux@bf8bbd9 · GitHub. So I would be curious if the problem will be resolved for you when Fedora updates to 6.3.