Bluetooth keeps disconnecting: OS or DE issue?

Lenovo P1; Fedora 34; KDE (Breeze Dark)

Bluetooth keeps disconnecting. (1) Is this a Fedora issue or a KDE issue? (2) Any suggestions on how to diagnose and repair? New to Linux.

Hi! Maybe I can help.

What’s the output when you type “journalctl” into the terminal? To rule out KDE, I’d also try installing Gnome and checking to see if it persists there, or in any other environment.

1 Like

Hi. Thanks. I won’t be able to get back to the machine until this weekend. I’ll do as you suggest then, and report back.

There are over a thousand lines of output. I broke the process after line 1343 or so, assuming that’s too much to put here. I could provide a link, or is there a way to output just the piece that might be illuminating?

Same result under Gnome. With all updates for Gnome, KDE, F34, and my Bluetooth device: Bluetooth appears to be on; my Sennheiser TW2 are paired; they connect; and then in the blink of an eye they disconnect. Not sure where I should be looking for a fix…

Your test proves that neither KDE or Gnome is responsible for this. If there’s some word that should show up in every line of your journal referring to bluetooth (I don’t use it, so don’t know.) you can filter the output from journal through grep, or use an option to have journalctl only show the relevant lines (again, I’m not familiar with the command’s details) and either redirect it to a file or use tee to watch the output while it also goes to a file.


Hello, again! I agree with @sideburns, it doesn’t sound like a Gnome or KDE issue.
My Fedora 34 install is using bluez for bluetooth, so I assume the same for your case.
Here’s a better command that’ll narrow it down a little. I’d connect your headphones and wait for them to error out, then run the following:

journalctl | grep -i “blue*” ← filter non-case sensitive for anything containing blue, (bluez, bluetooth, etc)

For me, that got it down to less than 1000 lines. Much better. Pastebins are probably what most people use. is an option to use, perhaps. Not used it a lot, but it’s been handy. Just change up the command a little so you get a file instead of output:

journalctl | grep -i “blue* | tee bluetooth_journal.txt”

Then (per aptget)
curl --upload-file bluetooth_journal.txt ← (generates a link…)

Hope this gets you closer to figuring out the cause.

Take care!

Even better would be to run

journalctl --follow

And then connect the headphones. Much simpler.

1 Like

Connecting the bluetooth device after running ‘remove device id’ command in bluetoothctl solved the problem for me. My bluetooth headphones showed problem out of the blue one day. Reinstalling bluez and restarting bluetooth.service, or unblocking rfkill all did nothing. But when I tried to connect my blaupunkt speakers it was connecting. Then I removed the device in bluetoothctl and connected again and did the trust and the headphones were working as before.

Just faced the same issue with Fedora 35 updated.

I had to remove the folder below, reconnect to the device (in my case a bluetooth speaker) and now it is working fine:

sudo rm -fr /var/lib/bluetooth